0

I am trying to run this command:sudo apt-get update && apt-get upgrade but I keep getting these errors

E: Could not open lock file /var/lib/dpkg/lock-frontend - open (13: Permission denied) E: Unable to acquire the dpkg frontend lock (/var/lib/dpkg/lock-frontend), are you root?

I read in another answer that by using sudo these errors will be solved. But in my case I'm already using sudo. How to solve these errors?

  • 2
    You need to use sudo on the apt-get upgrade as well; the command after the '&&' is a separate command so isn't covered by the sudo on your first command. – guiverc Feb 6 at 7:45
0

sudo apt-get update && sudo apt-get upgrade

the commands before and after && are separate commands, so sudo must be used by both commands.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.