2

Update 6 Feb 2020

(See below for original problem description.)

So, Ubuntu installed an auto-update today and after reboot, both Intel and AMD are being recognized.

$ DRI_PRIME=0 glxinfo | grep "OpenGL renderer"
OpenGL renderer string: Mesa DRI Intel(R) HD Graphics 4400 (HSW GT2)
$ DRI_PRIME=1 glxinfo | grep "OpenGL renderer"
OpenGL renderer string: AMD OLAND (DRM 2.50.0, 5.3.0-28-generic, LLVM 9.0.1)

Unfortunately, nothing had changed when I tried the Steam games, they didn’t use the dedicated GPU. Only when I edited the boot commands in Grub (sudo gedit /etc/default/grub – bit scary tbh, but I’m glad it’s even possible), like so:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash radeon.modeset=1 radeon.cik_support=0 radeon.si_support=0 amdgpu.si_support=1 amdgpu.cik_support=1 amdgpu.dc=1 amdgpu.dpm=1"

to force the use of amdgpu drivers instead of radeon, the games used the graphics card. I only tested Dark Souls 3 just now and it’s actually playable, although I had to turn down the graphics settings more than I had playing on Windows. I guess, it’s not that optimized? But that’s not relevant to the original problem, which is now solved.


The problem (5 Feb 2020, solved)

After I tried to make my dedicated Radeon graphics card work in addition to the integrated Intel graphics, Ubuntu installed drivers with an automatic update. Now neither Intel nor Radeon is being used, but instead it says llvmpipe (LLVM 9.0.1, 256 bits) in Settings/Details/About/Graphics, nothing graphics intensive works well, and I cannot get it to at least use the Intel graphics again.

The initial setup

I have installed Ubuntu 18.04 three weeks ago on a Acer TravelMate P645MG notebook with a dedicated AMD Radeon HD 8750M graphics card (previously Windows 7, now dual boot; I have no prior experience with Linux). From the outset the Radeon was not listed in the Settings/About panel, but the Intel HD Graphics 4400 was listed and seemed to work fine.

Then I installed Steam, hoping that this would install additional drivers for the Radeon. Steam installed Proton, but the game I tried (Dark Souls 3) crashed on launch. Steam then automatically installed Vulkan on next launch: now I could launch the game, but it crashed on character generation screen. I assume the game tried to run on Intel and didn’t use the Radeon.

Portal (original) ran fine on the Intel, actually, if that’s of any interest.

Steps in between

I researched the problem in many forum threads, but I was wary of trying out suggested solutions because so many of them were really old and I had read several times that the Radeon drivers installed with Ubuntu 18.04 were really good and should work out of the box.

I did eventually install the ppa:oibaf/graphics-drivers package, but nothing changed. Some people recommended setting the dedicated graphics card as default in the BIOS, but mine doesn’t have an option for that.

When things went wrong: Ubuntu update

Two days ago, Ubuntu prompted me to install an automatic update, which included Mesa and/or OpenGL drivers (I don’t know what any of that means, really). I hoped that would solve the problem, so I installed and rebooted.

Shortly after reboot, when I opened a program, Ubuntu crashed to some kind of full screen terminal view. I rebooted again and Ubuntu worked, but now it said llvmpipe (LLVM 9.0.1, 256 bits) in Settings/Details/About/Graphics.

I assume that this is a bad thing, because my games crash on launch again (test with Portal: launches but unplayably sluggish) and my notebook runs hot even when I play Netflix videos.

What I have already (not) tried

I would have liked to revert the Ubuntu update, but I don’t really know what I’m doing and I’m afraid I’ll do more damage. Right now, playing Steam games is not even my main concern anymore (I can boot up Windows for that, I had never expected that Steam even existed for Ubuntu) -- but I want Ubuntu to at least use the integrated Intel for everything else.

If anyone can help, I’d be forever grateful! :)

Stuff

Information that was requested on other threads, I hope this helps:

$ lspci -k | grep -EA3 'VGA|3D|Display'
00:02.0 VGA compatible controller: Intel Corporation Haswell-ULT Integrated Graphics Controller (rev 09)
    Subsystem: Acer Incorporated [ALI] Haswell-ULT Integrated Graphics Controller
    Kernel driver in use: i915
    Kernel modules: i915
--
02:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Mars [Radeon HD 8670A/8670M/8750M]
    Subsystem: Acer Incorporated [ALI] Mars [Radeon HD 8670A/8670M/8750M]
    Kernel driver in use: radeon
    Kernel modules: radeon, amdgpu

$ DRI_PRIME=0 glxinfo | grep "OpenGL renderer"
OpenGL renderer string: llvmpipe (LLVM 9.0.1, 256 bits)

$ DRI_PRIME=1 glxinfo | grep "OpenGL renderer"
OpenGL renderer string: llvmpipe (LLVM 9.0.1, 256 bits)
  • What is the question? – Pilot6 Feb 6 at 14:14
  • The question was “How can I fix the problem and tell Ubuntu to use the correct drivers for my machine?” (it’s done that by itself, it seems, as described in my update). – Zyb Feb 6 at 14:18
1

I had a very similar occurrence with my Intel HD Graphics 5500 card being replaced with the OpenGL renderer LLVMpipe you mention -- at the exact same time you reported. Did you enable the advance graphics-drivers ppa (ppa.launchpad.net/oibaf/graphics-drivers) before or after the issue? In my case, it appeared to cause my issue. After a Feb 6 update (same date as your issue):

- My current Wayland session quietly restarted in X.org without comment
- Wayland session disappeared from the GDM3 login options
- Celluloid, a ppa-based fork of gnome-mpv disappeared as the default application for media player, and the default reverted to mpv
- Apt reported a number of graphics libraries "no longer needed and autoremovable" -- INCLUDING gnome-mpv (ppa name alias Celluloid) -- even when Celluloid was explicity installed (NOT as a dependency)

Purging the advance graphics-drivers and reverting to the repo-based drivers removed LLVMpipe and restored my Intel HD Graphics 5500 (Broadwell GT2.)

sudo ppa-purge -o oibaf -p graphics-drivers
sudo ppa-purge -o xuzhen666 -p gnome-mpv

I also purged the gnome-mpv ppa, then later re-installed it. I think the ppa-based advance graphics drivers may have listed gnome-mpv as a dependency or recommendation.

HTH. Even if this turns out not relevant to your instance, maybe it can help others.

| improve this answer | |
  • Thank you for the response! Yes, then it was the exact same problem because I also installed the oibaf drivers before the problem appeared. I also tried to deinstall it by unchecking/removing the package in Ubuntu’s "Software & Updates" interface (tab "Other Software") – but I’m not sure whether that purged it. And after nothing changed, I re-installed the package. So, I can’t really know whether it was an update for the Ubuntu drivers or the advanced drivers that fixed the bug. – Zyb Feb 14 at 19:56
  • ppa-purge will reset all packages from a PPA to the standard versions released from repositories. I suspect that removing a PPA from the Sources list may not have the same effect. You need to install ppa-purge (use apt install) -- but but you may have to re-enable the oibaf ppa in order to purge and restore repo-based packages. – user173876 Feb 15 at 23:07
  • On the other hand, it's very possible that you can simply stay with the ppa, and a new update will eventually fix the regression problem. This ppa was releasing updates daily, so I think this is very probable. I purged because I don't think I was seeing any significantly noticeable improvement. – user173876 Feb 15 at 23:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.