9

I installed drRacket in Ubuntu by downloading the source file from here. I then ran

sudo ./racket-5.2.1-bin-i386-linux-ubuntu-karmic.sh

after making it an exe file so the file is in the usr/racket/bin/drracket

  1. I want to run it from command line without going to its directory

  2. I cant make the drRacket to run the .rkt files by the "open with"

2 Answers 2

7

Open Terminal and enter these commands to add the Racket PPA:

sudo add-apt-repository ppa:plt/racket -y

and install:

sudo apt-get install racket -y

You can run it by entering drracket or opening it in Applications menu.

1
  1. Add /usr/racket/bin to your PATH. If you use bash (which is the default for the terminal in Ubuntu), you would edit your .bashrc file to have the two lines:

    PATH=/usr/racket/bin:$PATH
    export PATH
    

    If your .bashrc already has a PATH setting, then you need to add /usr/racket/bin to it. For example, I already have a PATH setting that looks like: PATH=~/bin:$PATH. I would then change it to: PATH=/usr/racket/bin:~/bin:$PATH. The colons act as separators while $PATH will include whatever your default environment PATH is. Bash will look in the locations in the order listed, so actually I would probably prefer PATH=~/bin:/usr/racket/bin:$PATH so that my personal scripts (which I put in ~/bin) would be picked over anything else.

    If you don't have a .bashrc in your home directory, make one using your favorite text editor with the two lines above.

    The modification won't take effect until you open a new terminal or you type source .bashrc in the current terminal.

  2. Add drRacket to the "open with" submenu of the right-click menu. I think you are probably using the default file manager, Nautilus. I don't use that anymore but my understanding is that people have been having problems with this. See this answer for a solution.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .