In Ubuntu 18.04, when pressing media buttons on my keyboard, the volume is (de/)increased by around 6%. How can I make the change smaller?

Every solution I've found on the internet doesn't seem to work in Ubuntu 18.04...

  1. There is no longer volume-step to change in dconf...
  2. Replacing the default action of media buttons from XF86AudioLowerVolume to amixer set Master 1- would work, but then you don't get the GUI notification pop-up with the current volume.
  3. Pressing Shift+ is ok, let me regulates with 2% step, but I don't want to press Shift. I just want to be able to use my volume scroll on the keyboard and adjust the step myself.

Seems that dev hardcoded those values... Is there something you can recompile yourself to change it? Or is there a way to invoke this sound volume GUI popup manually? So this could be used with option 2.

  • Pressing +/- is 20 steps. Scroll wheel Up/Down on the speaker icon with the mouse. does 50 steps. So that might be an option too.
    – Rinzwind
    Feb 5, 2020 at 14:28
  • Well yes, but I have a very convenient scroll / roller on my keyboard that I got used to. It's sad that Ubuntu/Gnome removes config options, following main trends of treating users as idiots that are overwhelmed with too many options.
    – zupazt3
    Feb 5, 2020 at 15:29
  • 1
    Does this answer your question? How can I make the volume change in smaller increments? Aug 18, 2020 at 11:30

1 Answer 1


I know that the original question asks about 18.04, but in 20.04 there is now a setting for this:

dconf write /org/gnome/settings-daemon/plugins/media-keys/volume-step 2

Replace 2 with your desired step value.

Reference: https://bugs.launchpad.net/ubuntu/+source/gnome-settings-daemon/+bug/871133

  • 1
    I guess, it's time to switch to 20.04 in that case ;)
    – zupazt3
    Aug 18, 2020 at 11:37
  • 1
    Awesome, thanks!
    – rvargas
    Jun 14, 2021 at 2:10

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .