0

So I have an Ubuntu server 18.04 and in my home folder I have the following files and dirs :

(0) matias #> ls -lh
total 24K
drwxrwxr-x  2 matias matias 4.0K Feb  5 12:44 Desktop
drwxrwxr-x  3 matias matias 4.0K Dec 11 19:42 Ubuntu_bash_profile
-rw-rw-r--  1 matias matias   15 Dec 12 15:16 food.txt
drwxr-xr-x 10 matias matias 4.0K Oct  6 20:30 go
-rw-rw-r--  1 matias matias  322 Dec 15 21:35 module.cpp
drwxrwxr-x  2 matias matias 4.0K Jan 27 15:44 test

I used to have more files and dirs but I deleted most of them as I am doing a clean up.

The strange thing is that when I run this command :

rm -fr Desktop/

I dont get any error but the folder is simply not deleted. I tried several times and I cant get rid of it.

Using sudo did not work either.

This is more information about the directory :

(0) matias #> ls -lhd Desktop/
drwxrwxr-x 2 matias matias 4.0K Feb  5 13:28 Desktop/

(0) matias #> getfacl Desktop/
# file: Desktop/
# owner: matias
# group: matias
user::rwx
group::rwx
other::r-x

(0) matias #> lsattr Desktop/
...

What could be the problem here?

Edit : I recently installed xfce and vnc on it, could this be the reason? If so, how does this impedes me from deleting the folder anyway?

  • 2
    Perhaps it is being deleted - but is being re-created (by xdg-user-dirs-update for example)? – steeldriver Feb 5 at 13:44
  • Oh I understand. Yes, I got it. Thanks @steeldriver. If you post this as an answer Ill highlight it as the right one – Matias Barrios Feb 5 at 13:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.