0

I created a Linux Live USB key with Ubuntu 18.04 and turned off Secure Boot on my Surface Laptop 3, but whatever I try it just fails to boot! :-(

Regular boot (has "quiet splash" option)

-> MODSIGN: Couldn't get UEFI db list

Boot in compatability mode (has "nosplash" option)

-> hdaudioC0D2: Unable to bind the codec

No success with other versions of Ubuntu and Linux Mint I tried either. I tried modifying the boot options manually but I'm not sure how to turn off or choose a different audio driver/codec.


Regular boot after removing "quiet splash" option

Laptop starts getting loud and overheating after the line

[ OK ] Started udev Kernel Device Manager.

Regular boot after replacing "quiet splash" option with "text"

Either the same as above happens or I get this output:

A start job is running for Set the console keyboard layout (13s / no limit)
Kernel panic - not syncing: Timeout: Not all CPUs entered broadcast exception handler
1

What ended up working for me was

  1. When booting, edit the command line (press e) to add noapic to boot options
  2. Use Ubuntu Mate instead of Linux Mint because Cinnamon kept crashing
  3. Install kernel debian-test-2 from here so keyboard touchpad etc. work
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.