0

I'm using TigerVNC Viewer to connect from Windows 10 to my Xubuntu PC. It works fine, except with some colors. For example, when opening a configuration file with vim, the strings were shown in red. Especially the comments are really annoying, because the dark blue color is nearly unreadable:

enter image description here

The used Numix theme doesn't cause this. For comparisation, I opened the same file on a native screen, directly connected to the same Xubuntu machine:

enter image description here

How can I fix this to make the remote VNC colors look like the native ones from Xfce?

I already looked in the VNC viewer settings and couldn't find any suspicious settings: Colors are already set to full. Compression were enabled. For testing purpose I disabled both, no effect. The same for Auto select.

enter image description here

  • 1
    That isn't related to your gui, but the colored scheme used in vim. Change your vim theme. – guiverc Feb 3 at 9:28
  • You're right! But strangely :colo shows default on both VNC and direct connection. Both use the same user account. By randomly trying the avaliable themes I found that the theme from the second secreen is called ron. By setting colo ron in my ~/.vimrc it's now consistent on both sessions. I don't full understand why the physical session uses ron and vnc not, but this works - thank you! – Daniel Feb 3 at 10:24
  • 1
    Does this answer your question? How do I enable full-color support in Vim? – guiverc Feb 3 at 10:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.