Trying to set up an initial backup in Ubuntu 18.04 on google drive with a deja-dup installed as follows due to a known authentication error:

snap install deja-dup --classic --beta

The backup fails at the very end with the following error:

screenshot error

Backup Failed

Giving up after 5 attempts. RedirectMissingLocation: Redirected but the response is missing a Location:header

It sounds like the error reported here, caused by a broken httplib2 version 0.15.0, however my httplib2 version is 0.9.2 according to apt and pip3.

edit: updated httplib2 to 0.17.0 through pip3, but to no avail. Backup still fails at the very end after running for several hours and uploading 80GB onto google drive.

edit2: installed google-auth-httplib2 through pip3 and restarted laptop, but to no avail either.

edit3: installed google-auth-httplib2 through pip and restarted laptop, but again to no avail. Is there a way to check which httlplib2 Backup is using and to get some debug output?

2 Answers 2


There was a bug with httplib2, the developers released a hotfix for it. See here

As you have the snap version, it doesn't make a difference what dependencies you have installed, all dependencies are resolved in the Snap.

As such the accepted solution is wrong, their instructions will only affect users who do have deja-dup installed from the apt repository.

  • I see, that explains why it miraculously started working a week ago. And here I thought it was due to the packages I installed a month ago.
    – jpb
    Mar 23, 2020 at 15:09

There are broken dependencies in duplicity

First install librsync-dev

apt install  librsync-dev

and than in order:

pip3 install httplib2
pip3 install google-auth-httplib2
pip3 install duplicity
pip3 install apiclient
pip3 install PyDrive

Now I have perfectly running duplicity backup with GD

google-auth-httplib2 (0.0.3)              - Google Authentication Library: httplib2 transport
  INSTALLED: 0.0.3 (latest)
httplib2 (0.17.0)                         - A comprehensive HTTP client library.
  INSTALLED: 0.15.0

and duplicity:

duplicity 0.8.11



  • Thanks for the hint with google-auth-httplib2, I think that definitely goes to the right direction. I installed the packages you listed (both via pip and pip3) and restarted my laptop, but still get the same error at the end of the backup. Is there a way to get some info on Ubuntu backup (as in: which httlplib2 version it is using) and perhaps some debug info?
    – jpb
    Feb 6, 2020 at 13:36
  • Have you tried the non-snap version of deja-dup? Feb 6, 2020 at 16:06
  • I used only pip3 only, and duplicity (actually it makes the backup) I've installed with pip3 as well. apt install librsync-dev was crucial as well.
    – Dimitar
    Feb 8, 2020 at 21:59
  • @OrganicMarble I started with the default version of deja-dup on Ubuntu, but I encountered the following authentication bug, which I resolved by using the snap version: bugs.launchpad.net/deja-dup/+bug/1747646
    – jpb
    Feb 21, 2020 at 13:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.