13

I installed Ubuntu 18.04 on my new HP elitebook 850 G6 after erasing windows. I could not get audio input part working though.. Fn F8 key is orange all the time and this is how settings looks like.

sound

I installed pavucontrol, but that didn't change anything. What I have noticed is that I cannot check "set as fallback" permanently.

pavucontrol

Also tried editing /etc/modprobe.d/alsa-base.conf by adding

options snd-hda-intel model=auto

Sound control still does not recognize any microphone

  • Maybe check my answer on this post askubuntu.com/questions/508221/…. Some controls only show up in pavucontrol when you already started a program which needs mic input. – oscar1919 Feb 2 at 11:46
  • 1
    didn't help..problem is that input devices tab still show "Microphone (unplugged)" even though i could choose a input from Recording tab – senseiwu Feb 2 at 12:16
  • 1
    @senseiwu - I have a similar issue w/ hp elitebook 840 - very frustrating - added a 50pt bounty - post a response if you figured it out to collect – meyerson Mar 28 at 4:08
  • 1
    @senseiwu - yes that what I did as well - which led me into another sad Ubuntu ditch - the sound and mic quality of HFP (hands free protocol?, as opposed to A2DP) is dismal, thats why I use arch on my other laptop - the internal mic works, see bugs.launchpad.net/ubuntu/+source/pulseaudio/+bug/1838151 for more context – meyerson Mar 28 at 23:39
  • 1
    IIRC the Fn Key switch is independent from the OS - have you tried booting in the BIOS and pressing the Fn+Key switch ? Its also worth checking out all the BIOS options, since HPs Elitebooks series is for enterprise use, there are a ton of options you would not normally see in a BIOS. I just checked the BIOS manual for HP and there seems to be an option to enable/disable it there (page 40) – Robert Riedl Apr 1 at 6:10

Browse other questions tagged or ask your own question.