1

I just upgraded Ubuntu 16.04 to 18.04 and one of the issues I'm facing is that I can't view any folders and files because Nautilus crashes as soon as I try to open it:

$ nautilus
Initializing nautilus-dropbox 2019.02.14
Bus error (core dumped)

However, it works normally if I run sudo nautilus.

This makes me think there may be due to some sort of permission error.

How can I check which (if any) file Nautilus is trying to read which is causing it to crash?

Things I have tried

  • reinstall nautilus

  • make sure config files are owned by me: $ sudo chown -R felipe:felipe ~/.config/*

  • make sure dropbox config files under ~/.dropbox/ and under ~/.dropbox-dist are owned by me

  • list all files under my home and chown all configs and cache related files. (I couldn't chown /.gvfs and ~/.cache/doc, I get Function not implemented error message)

  • purge package nautilus-dropbox (it is not installed at all)

  • purge dropbox. Same error message but without the previous dropbox-related debug text:

    $ nautilus
    Bus error (core dumped)
    
  • ran strace nautilus for debugging. Last lines of log are here

PS the log message for when the nautilus app crashes at startup is different from the one I get when running nautilus on the cmd line. Here is the log for the startup crash: https://pastebin.com/mVx0E7SE

  • 1
    This is caused by running nautilus with sudo. That's a bad practice. You have nautilus config files owned by root. – Pilot6 Feb 1 at 20:23
  • I only ran it with sudo when it started crashing when running normally without sudo. – Felipe Almeida Feb 1 at 20:24
  • What about ~/.dropbox files? – Pilot6 Feb 1 at 20:25
  • Yep those too. Updated the text. – Felipe Almeida Feb 1 at 20:27
  • Does the issue also happen in another user account? – vanadium Feb 2 at 19:16
2

I suggest removing nautilus-dropbox by

sudo apt purge nautilus-dropbox

If you need a Dropbox service, you'd better install it from the Dropbox site.

https://www.dropbox.com/download?dl=packages/ubuntu/dropbox_2019.02.14_amd64.deb

If nothing helps you can create a new user and copy files from the old user to the new one. This should help for sure.

|improve this answer|||||
  • but how can I know it's related to dropbox? – Felipe Almeida Feb 1 at 20:30
  • 2
    Did you read the error message? :-) – Pilot6 Feb 1 at 20:30
  • This package is not installed – Felipe Almeida Feb 1 at 21:05
  • Try to remove dropbox by sudo apt remove dropbox then. – Pilot6 Feb 1 at 21:06
1

You have entered into the World of Hurt (tm) that comes from running GUI programs as root. Avoid repeating that mistake.

Details: The "running-as-root" GUI programs grab ownership of all sorts of files, then,, when $USER tries to access the them, $USER cannot, because they're owned by root, and $USER doesn't have write access to the files, BOOM.

Take a look at the last few pages of lines of strace nautilus to get a look at what was going on leading up to the Bus error message, which probably means out-of-range memory access (or, out-of-permissions).

Check /var/crash, one can less the crash files.

To find all the files in your $HOME directory that you don't own:

sudo find $HOME \! -user $USER -ls

If, after inspection, cogitation, and reinspection, you want to regain ownership:

sudo find $HOME \! -user $USER -print0 | xargs -0 -r sudo chown $(id -u):$(id -g)
|improve this answer|||||
  • chowned all relevant files, still having the error. These are the last lines of the output of strace nautilus: pastebin.com/jBDURhpm – Felipe Almeida Feb 1 at 23:29
  • Replace $HOME with /run/user/1000/dconf in my answer. Pesky root GUI proggies! – waltinator Feb 2 at 1:09
  • Sorry... also didn't work. There's was a single file user and it was owned by me =/. I added another point to the text about the startup crash. – Felipe Almeida Feb 2 at 1:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for?Browse other questions tagged or ask your own question.