The Desktop Icons GNOME extension in Ubuntu 19.10 is not working properly. Double clicking an icon produces a notification saying there is an error:

Execution of "PATH_TO_FILE"
Command not found

I have found another desktop icons extension that works much better. However, Ubuntu does not let me turn off or delete the default extension, and it interferes with the new extension. Using the Synaptic Package Manager says it will also remove ubuntu-desktop and ubuntu-desktop-minimal. Is there a way to remove the extension safely?


The pre-installed system extension 'Desktop Icons' keeps its config files in the /usr/share/gnome-shell/extensions/desktop-icons@csoriano/ directory. If you're absolutely sure, you can disable the extension by removing this directory. It is highly recommended to just rename the directory so that if anything goes wrong you would be able to recover by reverting to the original name.

Note that this directory would most certainly be re-created after an upgrade to an associated package. So you would have to repeat the renaming part after each such update.

  • I followed these instructions, and after logging in and out, I installed Desktop Icons NG (DING) (a really odd name!), which is far superior. Everything works well now, including previously-missing functionality. Thank you. – Paddy Landau Sep 21 '20 at 12:22

To disable the default desktop icon extension, run the built-in Extensions application. Then find 'Desktop Icons' under the Built-In section, and disable it there.

For some reason it's not possible to disable the extension using the Tweaks application, which also lists GNOME Shell extensions. But the Extensions application works fine for this purpose.

  • Thank you for this. I was trying to disable this extension via Tweaks and couldn't figure out why it wasn't working. Using the Extensions application did the trick. – Garret Heaton Feb 5 at 19:48

To be clear: I don't (!) use Ubuntu 19.04 or later like Eletwo and had installed the Desktop Icon extension manually.

When I wanted to find the config files of my manually installed "Desktop Icons" extension (in order to change them), I couldn't find them where pomsky suggested, but instead at: ~/.local/share/gnome-shell/extensions/desktop-icons@csoriano

Just in case somebody else has troubles finding them and ends up here, like I did.

This might seem obvious in the manually installed case: For deleting the extension, what worked for me is using the GNOME shell intregration Add-on in Firefox (where I had installed it) -> Installed extensions: https://extensions.gnome.org/local/


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.