0

I tried to install a fresh Ubuntu (18.04.3) on my new ASUS UX301LA internal drive. Previously, there was Ubuntu installed, but on an old disk. After struggling with problems booting the live usb (mmx64.efi not found), Ubuntu is now installed as encrypted system but it doesn't boot. There is no dual boot or similar, before installing the hard drive was blank. I'm aiming to use Ubuntu as the single OS.

After starting the device, I'm only able to enter the bios. There is no boot drive to select.

I ran Ubuntu's Boot repair which doesn't help directly, here's its report: https://paste.ubuntu.com/p/rjdz6QBJJp/

What i tried

  • Repairing the disk via Boot Repair
  • installing an unencrypted Ubuntu, same problem
  • setting own partitions in order to avoid misssing EFI partitions or similar
  • setting an mmx64.efi in /BOOT/EFI because it helped getting the live usb running, here it doesn't

In EFI-partition, EFI/ubuntu/grub.cfg looks like this:

search.fs.uuid 2b4b936b-4ab9-b23c-832f23309e6d root hd0,gpt2

set prefix=($root)'/boot/grub'

configfile $prefix/grub.cfg

But there is no grub.cfg. Is this a problem?

Latest boot repair report (4 Feb): http://paste.ubuntu.com/p/DY2NhScCZr/


More tries:

Super Grub 2

Using Super Grub2 Disk, I was able to enter grub. hd0 cannot detected, no file can be found: https://i.stack.imgur.com/bWmOY.jpg

Older Version

trying ubuntu 14, the installation process ends with this:

The 'grub-efi-amd-64-signed' package failed to install into /target/. Without the GRUB boot loader, the installed system will not boot

Running GRUB2 via Live usb

These partitions/drives are shown when ls in GRUB2 via live usb:

(memdisk) (hd0) (hd0, apple2) (hd0,apple1) (hd0,msdos2)

Updating GRUB I tried to update GRUB via Live usb. I chrooted disk and tried update-grub2:

failed to get canonical path of '/cow'

  • 1
    Rerun Boot-Repair in UEFI boot mode from Ubuntu live installer, but mount LVM and decrypt your install. It needs to see fstab. Then do a full reinstall of grub using advanced mode. sourceforge.net/p/boot-repair/home/Home & phoronix.com/… Old info: help.ubuntu.com/community/AsusZenbookPrime – oldfred Jan 29 at 16:59
  • @oldfred Running with grub reinstall after decryption worked, thank you. Unfortunately, I'm furthermore not able to run ubuntu from disk, here's the new report: paste.ubuntu.com/p/KSW33XJJNs – degers Jan 29 at 20:03
  • If you press escape right after UEFI screen, do you get grub menu? With only one system, it automatically boots, so not sure if grub loading issue or further along and boot issue. If you get grub menu can you use recovery mode and get to terminal? Or does it then boot? Or remove quiet splash on grub line in boot stanza's linux line (e for edit at grub menu). Then your see boot process. Error often not last line when it stops, but several lines above. – oldfred Jan 29 at 21:04
  • Without live usb or boot repair I'm not able to get access to disk. With pressing Escape, I'm entering a boot device selection, where only "enter setup" is given (when there is no stick). That's why I can't even try to do something with system on drive. Same in Boot order, nothing given. Even running hard disk Ubuntu via live usb doesn't work. Maybe I have to find a way to reinstall Ubuntu in an EFI, not in a legacy way – degers Jan 29 at 21:12
  • Have you updated UEFI to newest available? And if now SSD, updated SSD firmware? Is drive in UEFI settings at AHCI, not RAID nor Intel RST? You are showing an ESP - efi system partition so in UEFI boot mode. If you want BIOS/Legacy/CSM, you will need a bios_grub partition of 1 MB unformatted. – oldfred Jan 29 at 23:45
0
  1. Download the Boot Repair iso file.

  2. Make a bootable Boot Repair live USB flash drive with Rufus or UNetbootin. If you have a Debian-based distribution handy you can also use Startup Disk Creator to make a bootable Boot Repair live USB flash drive.

  3. Boot from the Ubuntu USB flash drive and install the OS until you get to this error message.

    The 'grub-efi-amd-64-signed' package failed to install into /target/.   
    Without the GRUB boot loader, the installed system will not boot  
    

    Continue the installation anyway until it finishes.

  4. Reboot the computer with the bootable Boot Repair live USB flash drive selected as the first entry in the boot priority menu of the UEFI/BIOS.

  5. Click the Recommended repair button in the Boot Repair menu and run it. You don't need to click any of the Advanced options.

  6. Reboot to the Ubuntu installer from the Ubuntu USB installation media.

  7. At the Installation type screen select the Replace ... with Ubuntu option where ... is whatever Linux you installed the last time. The Ubuntu installer may identify this Linux as "generic Linux" instead of Ubuntu because it has a different bootloader which was installed there by Boot Repair. This time the installer will run all the way through until the end and replace the grub that Boot Repair installed with the appropriate grub for Ubuntu.


Converting Ubuntu into UEFI mode

  1. Start Boot-Repair, and select Advanced options -> GRUB location tab.
  2. If you do not see a Separate /boot/efi partition option, this means that your PC does not have any UEFI partition.
  3. If you see a Separate /boot/efi partition option, put a checkmark in the checkbox to the left of it, then click the Apply button in the lower right corner.

    Separate /boot/efi partition

  4. Set up your BIOS so that it boots the hard drive in UEFI mode. The way to adjust this setting depends on the specific model of the computer, but generally this setting is located in the boot priority settings under the Boot tab of the BIOS/UEFI setup utility.

For more information about converting Ubuntu into UEFI mode review https://help.ubuntu.com/community/UEFI in the section about Converting Ubuntu into UEFI mode.

| improve this answer | |
  • Thanks Karel. Trying again to run Ubuntu 14, I didn't receive this error again. Instead, the installation was succesful, but, same as Ubuntu 18, no booting and no drive detected in uefi. I think the problem is that grub doesn't work. But I cannot try to resolve this problem because Boot Repair only starts in legacy. – degers Jan 30 at 19:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.