1

Installed a new Epson XP-830. This printer has a number of connection options, to include USB and wireless. I can't print wireless from Ubuntu 19.10.

  • Windows prints to either USB or wireless connection.
  • Ubuntu prints via USB connection.
  • Ubuntu network discovery finds the printer properly.
  • Printer added manually, or via discovery, neither prints.
  • Ubuntu won't print via wireless connection.
  • Epson printer drivers installed, no help.
  • Will print the CUPS "Test Page" fine.
  • Using Verizon MiFi hotspot for wireless.
  • Computer looks like the print cycle is complete, although the print queue empties very quickly, and the printer indicates that it's printing for about 3 seconds, but nothing prints.
  • How did you install it? Using passthru, ipp, or AppSocket? – Pilot6 Jan 29 at 16:08
  • @Pilot6 Thanks for your question. I believe that I tried all three... however, if one of them required a hard IP address, I didn't do that, as the IP can change, and then break the printer. I tried using the "discovered" printer, or the manually "added" printer, and neither would work. I makes all of the gestures like it should be printing, but it doesn't. I think some piece of software is missing. – heynnema Jan 29 at 16:11
  • I suggest to use a fixed IP. You can set a fixed one in your router, or in the printer. It works much better. – Pilot6 Jan 29 at 16:12
  • @Pilot6 Problem is, we don't have our own router... this is all being done via a Verizon MiFi hotspot... and I don't think it has the capability of assigning fixed IP addresses. – heynnema Jan 29 at 16:14
  • 1
    @user68186 Thanks for the input. I wondered about that too... but then Windows prints to it fine... so that "shouldn't" be an inter-device communication problem. And the CUPS test page prints. Very confusing. – heynnema Jan 29 at 17:03
1

Final solution...

  • set a valid static IP address in the printer (192.168.1.104)
  • "Added" a printer using "AppSocket/HP JetDirect" using the above IP address
| improve this answer | |
  • That's what I am always doing. – Pilot6 Feb 3 at 17:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.