1

Apologize if there is a duplicate of this problem, I just haven't been able to find the right solution on google..

Anyways, Hangul Toggle Key is not working for me, which means there is no way to switch between languages by keyboard. Korean input itself works, when I just left-click the ibus menu and left-click on "Hangul mode" toggle button, so it's not a language problem, just shortcut keys not working.

Alt_R key is not the problem, as I have tested even generic keys (such as 'f'), and the toggle still seemed not to work.

It had been working perfectly before (including the Hangul toggle key), so I'm presuming something else is breaking my configuration, but I just don't know where to start.

2
  • A simple 'ibus restart' solved my problem. Though I personally think restarting shouldn't be a solution.. should I report this as a bug?
    – 염준혁
    Jan 29 '20 at 3:59
  • OK it seems like it only doesn't work in Chrome. So maybe it's a Chrome bug? I need to develop on Chrome though, so I would still appreciate some help..
    – 염준혁
    Jan 29 '20 at 4:06
1

Can you try following the instructions here?

  1. apt-get install gnome-tweaks
  2. Run 'gnome-tweaks'
  3. Navigate to Keyboard & Mouse > Additional Layout Options > Korean Hangul / Hanja Keys
  4. Choose 'Right alt as Hangul'.

This worked for me, though 'ibus restart' didn't work so maybe my issue was slightly different.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.