2

I use Ubuntu 18.04.3 LTS (the machine is actually a VM that runs on VMware ESXi) and my VNC .xstartup file contains the following lines:

#!/bin/sh                                                                                                                                                                                                                                                                       

gnome-panel &
gnome-settings-daemon &
metacity &
nautilus &

When I connect to my desktop over VNC with the following command, I cannot open a terminal session in my VNC session:

vncserver :36 -geometry 1920x1080 -depth 16 -pixelformat rgb565

The following is the corresponding log file of my VNC session:

"28/01/20 16:59:12 Xvnc version TightVNC-1.3.10
28/01/20 16:59:12 Copyright (C) 2000-2009 TightVNC Group
28/01/20 16:59:12 Copyright (C) 1999 AT&T Laboratories Cambridge
28/01/20 16:59:12 All Rights Reserved.
28/01/20 16:59:12 See http://www.tightvnc.com/ for information on TightVNC
28/01/20 16:59:12 Desktop name 'X' (ubuntu-server:36)
28/01/20 16:59:12 Protocol versions supported: 3.3, 3.7, 3.8, 3.7t, 3.8t
28/01/20 16:59:12 Listening for VNC connections on TCP port 5936
Font directory '/usr/share/fonts/X11/75dpi/' not found - ignoring
Font directory '/usr/share/fonts/X11/100dpi/' not found - ignoring
/home/ayildiz/.vnc/xstartup: line 4: gnome-settings-daemon: command not found
metacity-Message: 16:59:13.508: could not find XKB extension.

(metacity:1210): metacity-WARNING **: 16:59:13.513: Failed to create MetaCompositorXRender: Missing composite extension required for compositing

** (gnome-panel:1208): WARNING **: 16:59:13.655: Failed to register client: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.SessionManager was not provided by any .service files

** (gnome-panel:1208): WARNING **: 16:59:13.692: Error opening directory “/usr/share/gnome-panel/applets”: No such file or directory
Gtk-Message: 16:59:15.152: GtkDialog mapped without a transient parent. This is discouraged.

28/01/20 16:59:22 Got connection from client 192.168.6.52
28/01/20 16:59:22 Using protocol version 3.8
28/01/20 16:59:26 Full-control authentication passed by 192.168.6.52
28/01/20 16:59:26 rfbProcessClientNormalMessage: ignoring unknown encoding 24
28/01/20 16:59:26 rfbProcessClientNormalMessage: ignoring unknown encoding 16
28/01/20 16:59:26 rfbProcessClientNormalMessage: ignoring unknown encoding 22
28/01/20 16:59:26 rfbProcessClientNormalMessage: ignoring unknown encoding 21
28/01/20 16:59:26 rfbProcessClientNormalMessage: ignoring unknown encoding 15
28/01/20 16:59:26 Using zlib encoding for client 192.168.6.52
28/01/20 16:59:26 rfbProcessClientNormalMessage: ignoring unknown encoding -314
28/01/20 16:59:26 Enabling full-color cursor updates for client 192.168.6.52
28/01/20 16:59:26 rfbProcessClientNormalMessage: ignoring unknown encoding -223
28/01/20 16:59:26 Pixel format for client 192.168.6.52:
28/01/20 16:59:26   8 bpp, depth 6
28/01/20 16:59:26   true colour: max r 3 g 3 b 3, shift r 4 g 2 b 0
28/01/20 16:59:27 Using raw encoding for client 192.168.6.52
28/01/20 16:59:27 rfbProcessClientNormalMessage: ignoring unknown encoding 24
28/01/20 16:59:27 rfbProcessClientNormalMessage: ignoring unknown encoding 22
28/01/20 16:59:27 rfbProcessClientNormalMessage: ignoring unknown encoding 21
28/01/20 16:59:27 rfbProcessClientNormalMessage: ignoring unknown encoding 16
28/01/20 16:59:27 rfbProcessClientNormalMessage: ignoring unknown encoding 15
28/01/20 16:59:27 rfbProcessClientNormalMessage: ignoring unknown encoding -314
28/01/20 16:59:27 Enabling full-color cursor updates for client 192.168.6.52
28/01/20 16:59:27 rfbProcessClientNormalMessage: ignoring unknown encoding -223
28/01/20 16:59:27 rfbProcessClientNormalMessage: ignoring unknown encoding 24
28/01/20 16:59:27 rfbProcessClientNormalMessage: ignoring unknown encoding 16
28/01/20 16:59:27 rfbProcessClientNormalMessage: ignoring unknown encoding 22
28/01/20 16:59:27 rfbProcessClientNormalMessage: ignoring unknown encoding 21
28/01/20 16:59:27 rfbProcessClientNormalMessage: ignoring unknown encoding 15
28/01/20 16:59:27 Using zlib encoding for client 192.168.6.52
28/01/20 16:59:27 rfbProcessClientNormalMessage: ignoring unknown encoding -314
28/01/20 16:59:27 Enabling full-color cursor updates for client 192.168.6.52
28/01/20 16:59:27 rfbProcessClientNormalMessage: ignoring unknown encoding -223
28/01/20 16:59:27 Pixel format for client 192.168.6.52:
28/01/20 16:59:27   16 bpp, depth 16, little endian
28/01/20 16:59:27   true colour: max r 31 g 63 b 31, shift r 11 g 5 b 0
28/01/20 16:59:27   no translation needed
Nautilus-Share-Message: 16:59:41.279: Called "net usershare info" but it failed: Failed to execute child process “net” (No such file or directory)
Error constructing proxy for org.gnome.Terminal:/org/gnome/Terminal/Factory0: Error calling StartServiceByName for org.gnome.Terminal: Timeout was reached
"

Everything was fine until yesterday and there was no such an issue. I tried to reboot the VM and also the hypervisor but it didn't work. How can I fix this issue?

This is an example on what I see via my VNC client.

enter image description here

3 Answers 3

1

Are you exporting your display server?

Also, try putting your gnome-settings-daemon first and add gnome-terminal to your vnc startup and see if that gets it to start on reboot.

7
  • What should I do to export my display server? Jan 28, 2020 at 14:22
  • you would normally add export DISPLAY=:1 to your session script or bashrc - :1 assumes your display sockets are free and unused - it may throw an error if other sessions have been started prior and have not been killed or purged. Jan 28, 2020 at 14:23
  • I've updated my post and added a screenshot of my VNC session. Could you please take a look at it? Jan 28, 2020 at 14:28
  • ok, so from what i gather, your session is running - dis you even install gnome-terminal? Jan 28, 2020 at 14:30
  • Yes, I did install gnome-terminal. Jan 28, 2020 at 14:32
1

Finally, it worked.

What I did was to run the following commands (I'm not 100% sure that this is a solution):

sudo apt-get update
sudo apt-get install --reinstall ubuntu-desktop gnome-panel gnome-settings-daemon metacity nautilus gnome-terminal
sudo apt-get update
sudo apt-get upgrade
0

Had the same problem. Use TigerVNC server to resolve this - https://www.cyberciti.biz/faq/install-and-configure-tigervnc-server-on-ubuntu-18-04/

1
  • Please edit your post and add a summary of the solution so that, in the event that your link is taken down, the community can still benefit from the answer. Thanks!
    – guttermonk
    Aug 23, 2020 at 0:13

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .