5

I am attempting to install the latest development version of Wine (wine-devel) under Ubuntu 18.04 Bionic Beaver from the WineHQ PPA but the following error message stops me:

andrew@corinth:~$ sudo apt install --install-recommends winehq-devel
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 winehq-devel : Depends: wine-devel (= 5.0.0~bionic)
E: Unable to correct problems, you have held broken packages.
andrew@corinth:~$ 

How do I successfully complete the installation of Wine Development version under Ubuntu 18.04? I would prefer to use only the Wine PPA and not add another PPAs such as the OpenSuse Build Service as suggested in other Ask Ubuntu answers...

7

This error comes about because WineHQ wine-devel now requires the installation of an FAudio package for installation to succeed. Fortunately this can be worked around fairly easily under Ubuntu 18.04 by using the following 3 relatively simple steps:

1. Add the Wine PPA

You will need to add the 32bit architecture to your 64bit system as well as add the Wine PPA and key:

sudo dpkg --add-architecture i386
wget -nc https://dl.winehq.org/wine-builds/winehq.key
sudo apt-key add winehq.key
sudo apt-get update

2. Add FAudio

For Ubuntu 18.04 (a different approach is required for newer versions of Ubuntu) the following steps should be used next:

cd ~/Downloads
wget https://download.opensuse.org/repositories/Emulators:/Wine:/Debian/xUbuntu_18.04/amd64/libfaudio0_19.07-0~bionic_amd64.deb
wget https://download.opensuse.org/repositories/Emulators:/Wine:/Debian/xUbuntu_18.04/i386/libfaudio0_19.07-0~bionic_i386.deb
sudo dpkg -i libfaudio0_19.07-0~bionic_amd64.deb libfaudio0_19.07-0~bionic_i386.deb
sudo apt --fix-broken install

This is perhaps a little easier than adding yet another PPA, the OpenSuse Build Service PPA...

3. Install Wine -devel

And now finally install the latest development version of Wine:

sudo apt install --install-recommends winehq-devel

Finally test your installation, as seen on my own system:

andrew@corinth:~$ wine --version
wine-5.0
andrew@corinth:~$ 

And now you are right to go :)

References:

  • 1
    +1 but why would a package exist in a LTS version that cannot be installed because its dependencies cannot be satisfied? – Jon Bentley Jan 28 at 17:26

Not the answer you're looking for? Browse other questions tagged or ask your own question.