0

I can do sudo shutdown now in a terminal just fine. Using the GUI however, clicking "Log Out" in the whisker menu (or entering xfce4-session-logout in a terminal) opens a dialog window which shows (among other options) a "Shut Down" button which, when clicked, only logs me out instead of shutting down the system.

There seem to be quite a few questions about such problems, though none of them have led to a solution for me:

  1. When I click Shutdown, computer logs out instead of shutting down:
    • Since I use Xubuntu, the comments about Unity don't apply.
    • Instead, I tried the xfce4-session-logout --halt command, which does the same as clicking the "Shut Down" button, i.e. logging me out of my XFCE session.
  2. Shutdown button only logs out ubuntu 15.04:
    • I don't have Docky, Plank or Cairo-Dock installed, so the related answers don't apply.
    • There's another answer suggesting Unity Tweak Tool, but I don't think this is applicable to XFCE, so I didn't install it.
  3. Shutdown logs out instead of shutting down:
    • Though over 8 years old, the related bug appears to be unresolved still. Since this is about GNOME and not XFCE though, I'm unsure it'll help me.
  4. Shutdown or Restart only logs me out:
    • The only answer suggests that other users are currently logged in, which is not the case... if I enter who on the terminal, I am the only user shown.
  5. System won't shut down; Logs off instead:
    • There's a comment mentioning an AppArmor DENIED log entry which doesn't show up in my /var/log/syslog, but I do see messages such as kernel: audit: type=1400 audit(1580169596.570:34): apparmor="DENIED" operation="sendmsg" profile="/usr/bin/man" pid=13792 comm="troff" laddr=<my_ip_addr> lport=990 faddr=<gateway_ip_addr> fport=2049 family="inet" sock_type="stream" protocol=6 requested_mask="send" denied_mask="send" around the time I tried to shut down via the GUI button. Given the description though, I don't think they're related.
  6. I can't shut down nor reboot without console:
    • The only answer is about Rabbitmq being a problem, but I don't think I have that installed.
  7. "Shut down" takes me to greeter now?:
    • There's some info about Policykit dealing with the problem in the context of other users being logged in, which I don't think applies to my case, however digging into it a bit I found in my /usr/share/polkit-1/actions/org.xfce.session.policy something about Authentication is required to shutdown, restart, suspend, or hibernate the system which may be related, but I'm unsure what to try to fix the issue.
  8. This answer to "What mechanism prevents shutdown when another open session exists?" could also be helpful to investigate, where would I be looking for related logs?

The only odd thing about my system setup I could think of which may be of relevance is that my user & profile is not a local one but provided over the LAN via NIS/yp instead. I did have some experience with other system issues (e.g. audio not playing for a NIS user), which could usually be solved by simply adding the user to the relevant group with the permissions to accomplish what I wanted, but this one has been elusive so far.

Please let me know if I'm wrong on anything relevant in the above points, and any tips on where (else) to look for relevant error messages/logs are much appreciated.

  • You mean "clicking the "Shut Down" button" rather than "clicking the "Log Out" buttons" in the second line of your question? – vanadium Jan 28 at 10:00
  • @vanadium, thanks for the suggestion. It's a little confusing unfortunately: Actually the first button (the one in the whisker menu) is called "Log Out" - when clicked, it opens a dialog with several options, one of which is "Shut Down". Running xfce4-session-logout is equivalent to the former, i.e. shows the dialog. I have edited the question to clarify that. – FriendFX Jan 28 at 10:46
  • I had similar problems with my Xubuntu Voyager 18.04.2 LTS after automatic post-installation update to latest kernel 5.3.0-28. I tried to solve this problem by deleting this kernel with these 3 subsequent commands: 1.) sudo apt-get purge linux-image-5.3.0-28-generic; 2.) sudo apt-get purge linux-modules-extra-5.3.0-28-generic and 3.) sudo apt autoremove. Now I use original download kernel 4.18.0-15-generic. Result. No more problems with Shutdown, Restart and Sleep (suspend). – Kapel Jan 31 at 16:46
  • @Kapel thanks for your comment. If this was in a VM (or on a filesystem I could easily take snapshots with), I'd be happy to try this as well... but this is a production machine and I need it to work reliably daily, so I don't think I want to take that risk at this point. Apart from that, I suspect the problem to be caused by a higher-level misconfiguration rather than a low-level kernel issue. – FriendFX Feb 2 at 22:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.