6

In Xubuntu 18.x and Ubuntu XFCE 19.04, 19.10 (XFCE4, lightdm) I experience the un-lock screen does not show up. The screen remains locked!

Actually typing the password into the invisible lock sceen OPENS the lock!!!

That means the password request is working but does not show up. This is the reason why there are no error messages.

"light-locker-settings" explicitly tells me XFCE is controlling the "energy" settings. This works.

And there is no cover window over the GUI when it is "locked". The window in front of the main GUI does not show up (information not covered) and password entry does not show up.

QUESTION: How can I make the password request visible again??

10
  • Which release? Xubuntu 18.04 has a different XFCE version, Xubuntu 19.04 is now EOL & thus off-topic (ubuntu-news.org/2020/01/23/…) whilst Xubuntu 19.10 uses GTK3 only and is thus different to prior releases. Which are you using? – guiverc Jan 27 '20 at 8:24
  • The problem is the same in all versions. I guess the composer or window manager has some issue not specific to the underlying tools. Current is Xubuntu 19.10 with lightdm. How can I see if the Energy / lock / windowmanager is based on GTK3? Wht difference it will make? – opinion_no9 Jan 27 '20 at 8:29
  • ..... RN: "Xfce Screensaver replaces Light Locker for screen locking." Does this apply for upgrades?? – opinion_no9 Jan 27 '20 at 8:38
  • 1
    Check, if you have xfce4-screensaver running in 19.10. If so, it should be used for locking automatically. If not, you could configure it to autostart in "Session and Startup" dialog. – jarno Jan 27 '20 at 8:50
  • And remember to disable autostarting 'light-locker' in the same dialog. – jarno Jan 27 '20 at 8:58
3

light-locker is buggy, see e.g. Bug #1832960, Bug #1855753

In 19.10 you can use xfce4-screensaver for locking, instead of light-locker. In 18.04 (and in 19.10) you could use xscreensaver instead of light-locker. You have to install the screensaver first. Make sure only the one you use is autostarted during login in "Session and Startup" dialog.

You could use which locker you want with Xubuntu 19.10, see here for instructions. As an administrator you could use any locker with an older release, too, by putting your version of xflock4 script in /usr/local/bin. (Otherwise the default version at /usr/bin/ is used.)

11
  • sorry, this was the case all the time. the issue appears because xfce4-screensaver is the active process. light-locker is not in the process list. To have it bullet proof: can I de-install only "light-locker" without affecting other applications? – opinion_no9 Jan 27 '20 at 14:35
  • 1
    xfce4-screensaver was provided for older releases (18.04) by the Xubuntu team members (via PPA; launchpad.net/ubuntu/+source/xfce4-screensaver); I recall the requests on IRC to test it, but that was long ago.. – guiverc Jan 28 '20 at 4:39
  • 1
    At the bottom of the page I did link was the Xubuntu QA Staging PPA, Unit 193's & Jonathon F's PPA, all 3 of which contained the bionic code I would have tested on request (either Unit193 or Xubuntu QA) – guiverc Jan 28 '20 at 9:33
  • 1
    I removed light-locker completely - no difference. This is a funny configuration issue. In other sitautions like time triggered locking the unlock screen appears. Closing the lid there is the problem. Now I get used to typing my password into the void and sesame opens the door. I did not install a beta version. Not promising since the normal version does work fine for most people. So it is not a general issue resolved by an upgrade of the software version. Recap: xfce4-screensaver actually uses the lock screen when closing the lid but does not show it. 100% reproducible. – opinion_no9 Jan 29 '20 at 5:24
  • 1
    @jarno I'm sorry I mislead you: I exchanged the whole Linux system (now using U20.04 with XFCE4). Please pardon the lack of clarity. A matching bug report exists, as far as I remember. See jarno Feb 17 at 11:52 – opinion_no9 Apr 22 '20 at 19:41
0

Since I'm having the same issue (see the comments at answer #1, I did some research and found a solution.

It seems to be an bug of xfce4-screensaver (0.1.8-1) in ubuntu eaon.

Tomorrow on April 23th Ubuntu 20.04 LTS will be released. That providies xfce4-screensaver (0.1.10-0ubuntu1) which fixes the bug.

You can install the updated package now by downloading it from the via ubuntu package page: here the .deb for amd64

2
  • 1
    I'm still having this problem on 20.04 and version 0.1.10-0ubuntu1 – SkaveRat Oct 7 '20 at 3:02
  • @SkaveRat: yes, and Ubuntu 21 too .... Try this: sudo dpkg-reconfigure gdm3 and switch to gdm3 window manager. Does not hurt, is reversible and often solves the issue. Let me know! – opinion_no9 Nov 21 '20 at 19:15
0

The availability of the XFCE lock screen(s) DEPENDS on the window manager!

  • lightdm is NOT capable according to an error message first seen in U20.10.

  • gdm3 IS capable to enable the lock screen.

So the issue is partly resolved: It DEPENDS on the window manager.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.