5

I got an xbox Elite v2 controller

I followed this technique (as originally seen here) : Xbox One controller Ubuntu 18.04 ...to get the controller running.

The technique seems to be a functional solution for Xbox One S and Xbox One X controllers so I assumed it would function for the elite controller. And for the most part, I was correct.

Here are the steps I took, in order :

sudo apt install -y sysfsutils
echo '/module/bluetooth/parameters/disable_ertm=1' | sudo tee /etc/sysfs.conf
sudo reboot

I then turned on my elite controller and started scanning on it and from my computer and successfully paired the two.

This resulted in my controller being fully functional (and via bluetooth!).

I then wanted to change the default mappings on the buttons on the underside. For that, I had to go into windows and run the "xbox accessories" app which first updated my controller before I could map.

I successfully mapped what I wanted but now back in ubuntu the connection is less functional for the controller's triggers specifically, seemingly as a result of the update to the controller's firmware :

  1. The right trigger sends no input.
  2. The left trigger inputs as a right trigger
  3. left trigger input is received by the computer constantly from the moment the controller is paried to the moment it is unpaired.
  4. the "View button" (left of X/home) sends no input

How do I fix this?

4
  • How long has it been since you have disconnected it from your computer? I would suggest disconnecting it and connecting it to an XBox periodically, so that XBox can resync your controller, and fix whatever problems it may have. – Jeff Mar 11 '20 at 15:23
  • I reconnected it to a windows recently. there were no more firmware updates. I'll try again. (also please remove your answer. it doesn't really add anything. I don't think you deserve a downvote but people might interpret it as a correct answer even though it's not) – tatsu Mar 11 '20 at 21:58
  • Mabe this is helpfull. I can not test it. github.com/atar-axis/xpadneo – nobody Mar 12 '20 at 22:00
  • @nobody no this is not what I need. Not only does it not support bluetooth (so overall less functionality than the solution I used) but it targets the same two controllers (that are not mine). so i'd be back at square one. my issue is added by the elite specifically. – tatsu Mar 13 '20 at 7:34
0

Try mapping the controller specifically in Ubuntu, with a textfile that has all the correct input mappings listed, This would be done by modifying a general controller mapping file for X-Input (I believe thats what all of Microsofts controllers use) EX> LB = "4" or whatever and so on, and like you said it isn't triggering an input for some of the buttons and mistriggering for others so what you have is a basic misconfiguration issue caused by Windows likely trying to map it to a new controller architecture (perhaps something to do with the Series X, dunno why but its possible).

I would recommend first attempting to reset the controller entirely, if it has that function, as theres no reason for it to have updated at all if it was previously functional.

Second I would try finding or creating that mapping file, using a program that interprets the X-Input calls directly or doing it through terminal. JStest seems to be one for Xbox360 Controllers, which albeit limited could help with testing for the triggers and such, to ensure your controller is ACTUALLY sending a signal for those. (given it connects properly, which it should, or you could simply wire the connection while testing and then connect via bluetooth after ensuring that it is indeed not locked for any weird reason.)

Third, is getting the mapping correct in Ubuntu, either through the file I spoke of previously, or through the programs you wish to use with it. And also not connecting it back to your Windows partition or PC unless you want it to yet again be reconfigured for the Windows setup and change your mapping for it.( No idea why it would ever do that, usually controllers don't carry a mapping information whatsoever and its on the OS to determine how to read that info, but still.)

Hope this might give you a little insight on the process and help at all! I've been through a similar situation trying to set up controllers in an emulator that didn't even have a GUI, and required a txt file to be created for the inputs, all of which had no documentation and it was pretty annoying, but thats a good place to start.

AS A NOTE: You said you got it working with that code at the top, reconnected it to Windows, and then it broke. So I would also try (if you haven't) doing what you did in the beginning and then figuring out how to map the bottom buttons WITHOUT Windows, I'm sure you can read those input calls aswell if any others are sending.

4
  • there is no reset function. Microsoft doesn't roll that way. As per your last note : you do not understand my issue. I've installed many many new ubuntus (because of reasons) and everytime I do I test my controller so this first step of sysfsutils and disable_ertm=1 I've done many times and the results are identical every time. Before doing them the controller doesn't connect after doing them the controller connects. however the input issues I listed are there. the only time they weren't is before firmware update of which there was one and as I said that is irrevertable. – tatsu Mar 17 '20 at 17:35
  • for this to constitute a good answer I'd ideally like for you to include and example file that remaps right and left trigger, and the view button, along with the path for where that file goes. and for you to have successfully tested this. 360 controller will do. – tatsu Mar 17 '20 at 17:42
  • So you want me to do the work for you..... I understand you want me to have tried this, but I use a wired 360 controller that doesn't have this issue mainly, and for 2 you can use Wine and run the program required from Windows through it, if you haven't tried that. I was just giving you the advice nobody else had, and making sure you were up to speed with all of this before going ahead and doing your work for you. – honestlyscriptkiddie Mar 18 '20 at 6:16
  • I have access to windows. I ran the controller program just yesterday. there are not fine tune options it's just click update button or don't. I tried updating firmware again there haven't been updates since it was just the one. All of what you said constites what I automatically assumed. yes for 200 points I do want some help with this and not to do this alone. – tatsu Mar 19 '20 at 6:41
0

In the end updating to ubuntu 20.04 fixed my issue.

I use rocket league with proton with acceptable latency.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.