I am running 19.10 on a Lenovo flex 11 and all seems to be working smoothly. I regularly check for updates and often get something new installed apparently. Well, today I checked for updates and get the message "Failed to load repository information". My network connection is good...hello, my question is getting in here...so what is going on? Fetching e-mail works, surfing the web works, streaming works, but am unable to download repository information. What's up? results of update attempt:

tom@tom-Lenovo-FLEX-6-11IGM:~$ sudo apt update
[sudo] password for tom: 
Ign:1 http://dl.google.com/linux/earth/deb stable InRelease
Hit:2 http://us.archive.ubuntu.com/ubuntu eoan InRelease                    
Hit:3 http://us.archive.ubuntu.com/ubuntu eoan-updates InRelease            
Hit:4 http://us.archive.ubuntu.com/ubuntu eoan-backports InRelease
Get:5 http://dl.google.com/linux/earth/deb stable Release [933 B]
Get:6 http://dl.google.com/linux/earth/deb stable Release.gpg [819 B]
Hit:7 http://security.ubuntu.com/ubuntu eoan-security InRelease
Ign:6 http://dl.google.com/linux/earth/deb stable Release.gpg
Reading package lists... Done
W: GPG error: http://dl.google.com/linux/earth/deb stable Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 78BD65473CB3BD13
E: The repository 'http://dl.google.com/linux/earth/deb stable Release' is not signed.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

my ignorance is nearly complete, but it appears to me that something may be lacking in the place where updates live - I am grateful for the assistance I get here.

  • Please edit your question above to show us the complete output of sudo apt update – user535733 Jan 25 at 1:33

It seems that the signature for google earth is not verified ( and it seems that its a common problem with google earth) so try the following: Setup key with:

wget -q -O - https://dl-ssl.google.com/linux/linux_signing_key.pub | sudo apt-key add - 

Setup repository with:

sudo sh -c 'echo "deb [arch=amd64] http://dl.google.com/linux/earth/deb/ stable main" >> /etc/apt/sources.list.d/google.list'

Time to update now :

sudo apt update 
| improve this answer | |
  • 1
    this is the remedy and worked fine - problem solved – tom koehler Jan 30 at 1:10
  • 1
    would you mark the question as 'solved' – zguell Jan 30 at 11:59
  • 1
    I would mark the problem as solved – tom koehler Jan 30 at 15:50
  • No literally Tom Koehler, you should have the option to mark it as solved with a check mark. stackoverflow.com/help/accepted-answer it helps others too :) – Tmanok Sep 17 at 21:48

Not the answer you're looking for? Browse other questions tagged or ask your own question.