1

I have Ubuntu for WSL and for classes I need to run the bochs 32-bit emulator in a Linux environment in the schools' computer lab. There is an option for using SSH to access the environment and my files that are located on my account.

The prof. said that you should be able to run bochs through x server for windows (xming, cygwin x, etc...) and I have been able to get the graphical applications to work. But only when on the local host (ie. my computer) trying to run any of the graphical applications through ssh is not working.

I'm not really sure what I should or shouldn't be doing at this point as the prof isn't able to help me through this.

The x server is running through its default settings, so maybe I need to configure my school account to access my x server? Not sure how to go about doing this. Any help would be greatly appreciated.

  • WSL version 1 is not designed to support a graphical environment. Which WSL version is in use? A) At a Windows Commmand Prompt, do ver. Is the next-to-last numeric group version 18917 or higher? If not, you have WSL version 1. B) Open Windows Powershell and enter the command wsl -l -v . If WSL version 2 is installed properly, you will see the version number; if you don't see a version number, or if you see an error message you have WSL version 1. – K7AAY Jan 24 at 0:18
  • @K7AAY my Version number is Version 10.0.18362.592 so I believe that means I am on WSL version 2. To note I am able to run graphical applications when I am not ssh into my schools computer. For B.) it does not list a version number it just gives me the Arguments to run Linux binaries: list of all the different command types and usages. But I am fairly certain I am on WSL version 2. – A.Karwowski Jan 24 at 0:52
  • Realized I can not count. Obviously 18917 > 18362 – A.Karwowski Jan 24 at 1:01
0

Your next-to-last numeric group shows Windows version 18362 which is less than the Windows version 18917 required to run WSL2. You have WSL1 and have no graphical ability in WSL. Therefore, you must use the original set of POSIX tools for X server for windows (xming, cygwin x, etc...).

| improve this answer | |
  • 1
    So I am now running on WSL version 2. I have ssh into my schools computer, and i launched Xming server. I tried to export DISPLAY=:0 which seemed to work but when i tried to run a graphical application it says xterm: Xt error: Can't open display: :0 which was what was happening earlier before upgrading. Any thoughts on this? Thanks – A.Karwowski Jan 24 at 2:57
  • devblogs.microsoft.com/commandline/announcing-wsl-2 explains that although WSL2 is better, it's still not a complete Linux environment. I don't work with WSL, so I apologize for not knowing WSL2 would not solve the problem. – K7AAY Jan 24 at 18:07
  • 1
    No worries. Ive been able to hack together a solution that should work for my needs at the moment. Thanks for the advice and help tho – A.Karwowski Jan 24 at 18:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.