0

My goal is to access windows administrative shares from Ubuntu 19.10. This works perfectly fine if I enable SMBv1 on the Windows 10 machines. However I would like to use v2, at least.

What I have checked and done so far:

  1. disabled back to default SMBv1 on Win 10

  2. checked the SMB protocol version in Win 10: v2 is running

  3. ran successfully the samba installation tutorial Install and Configure Samba

  4. i can access the Ununtu shares from Win 10 just fine

  5. added to the smb.conf file:

client min protocol = SMB2 client max protocol = SMB3 was this part even needed?

  1. I tried both by IP and hostname: none work

P.S. Workgroup is "WORKGROUP"

1

In /etc/samba/smb.conf, you should add this:

[global]
    client min protocol = SMB3
    client max protocol = SMB3

In windows 10 you should edit this and enter in the Local Group Policy Editor (search in windows)

Computer Configuration -> Administrative Templates -> Network -> Lanman Workstation -> Enable Insecure Guest Logon - Enabled

| improve this answer | |
0

To get some insight into what may be occurring, try installing smbclient:

sudo apt update
sudo apt install smbclient

Then try connecting to see if you receive any error messages which can give some insight into this issue (replace the items in the brackets with the appropriate details):

smbclient //<IP or hostname>/<share> -U <connection user>
| improve this answer | |
  • smbclient is already the newest version (2:4.10.7+dfsg-0ubuntu2.4). 0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded. – Highlander Jan 24 at 9:40
  • owever, weirdly, now it works but only if I enter the entire path :) Instead of entering in the GUI just smb://hostname and having displayed all admin shares, now it only works if I enter the entire path smb://hostname/D$ – Highlander Jan 24 at 10:03
  • That's normal because you need a specific target when mounting SMB shares. – Jameson Jan 25 at 3:42
  • But then why does it work with SMB v1? – Highlander Jan 27 at 15:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.