1

A week ago, I updated Ubuntu on my ASUS X556U laptop from 18.04 to 19.10. (I did it in two steps: 18.04 to 19.04 and immediately 19.04 to 19.10) After this update I got a strange problem. My laptop cannot resume from suspend every third suspend/resume cycle. It is dead after the third suspend. No disk activity. Two suspend/resume cycles are good, the third fails. I am sure the problem is in nouveau and my NVIDIA GeForce 940MX card. I get the following error messages all the time:

**nouveau 0000:01:00.0: bus: MMIO read of 00000000 FAULT at 6013d4 [ IBUS ]**

Prior to version 18.04, I could not turn off my laptop if I suspended and resumed it earlier, because NVIDIA didn't stop. But, after the update to 18.04, I had no visible problems with nouveau. I don't see anything suspicious in logs, although I do not have much experience in analyzing logs.
Is there any idea what is going on? Is there anything I can do?

2
  • FYI: Ubuntu release-upgrades are only tested from one LTS to the next LTS (ie. 18.04 will be tested to upgrade to 20.04.1 prior to it's release), or from one release to the next so 18.04 to the next standard release (ie. 18.10). Skipping releases is not tested as officially users are recommended to re-install. It's possible to do what you did, but problems that may have been fixed (config changes) in the 18.10 cycle may not have been implemented as you skipped that cycle... – guiverc Jan 23 '20 at 22:35
  • Fortunately, I found an immediate workaround with which I can live. Since I assume that my problem is caused by Nvidia, I started pausing / resuming from a virtual terminal. Since then, I have not had a single case with the resuming problem. However, I am interested to resolve this problem correctly.. I missed 18.10, because Update Manager only offers me an update to 19.04. I did a two-step upgrade, I could easily do a three-step upgrade. What's done is done. Is there a good way to refresh config now? – yurad Jan 27 '20 at 18:49
0

Finally, I installed the propitiatory NVIDIA drivers. Since that I do not have this problem. Suspend/Resume works without glitches. (The installation of NVIDIA drivers was not "smooth". NVIDIA tried to activate Secure Boot in UEFI. However, all boot issue were easily resolved.)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.