2

I have lately installed Ubuntu 19.10 and wanted to connect to the printing services on a local network, shared for linux users via SAMBA. While this worked flawlessly with 18.04/18.10, it's stopped to work for me. On journalctl -r, I get the following error (parameters obfuscated) when pressing the Verify button in the Printer Properties dialogue:

gnome-control-center.desktop: Kinit for user@DOMAIN to access SERVER failed: Cannot contact any KDC for requested realm
gnome-control-center.desktop: Caught non-fatal exception.  Traceback:
gnome-control-center.desktop: File "/usr/share/system-config-printer/newprinter.py", line 2861, in on_btnSMBVerify_clicked
gnome-control-center.desktop:     os.O_RDWR, 0o777)
gnome-control-center.desktop: smbc.PermissionError: (13, 'Permission denied')
gnome-control-center.desktop: Continuing anyway..

Also, I repeatedly get a notification requesting SAMBA credentials when printing the test page (the queue lists the job as "held for authentication"). The latter might be because my credentials don't seem to be saved in the Printer Properties as long as their verification fails.

Although that problem seems to be somewhat older, I tried this recent recommendation from the Debian bug mailing list, suggesting to switch off Kerberos by altering the corresponding Python script. Please, read the details how to do this there. However, after doing this I get another error:

gnome-control-center.desktop: Caught non-fatal exception.  Traceback:
gnome-control-center.desktop: File "/usr/share/system-config-printer/newprinter.py", line 2861, in on_btnSMBVerify_clicked
gnome-control-center.desktop:     os.O_RDWR, 0o777)
gnome-control-center.desktop: smbc.NoEntryError: (2, 'No such file or directory')
gnome-control-center.desktop: Continuing anyway..                

Hope to get some help.

1

I believe you have hit bug #1849859

|improve this answer|||||
  • Thanks for pointing to that issue. Yes, it seems to be an unfixed bug. Maybe you can turn your answer into a real one, once the fix is deployed. Thx. – Mario Jan 24 at 12:35
  • looking forward to hear about the progress on that bug, thanks @andreas for the work!!! – Matifou Jan 30 at 1:38
1

In the meantime, people have found a workaround for the bug described here:

  1. sudo service cups stop
  2. In the file /etc/cups/printers.conf, sudo-change the line AuthInfoRequired none to AuthInfoRequired username,password in the block for your printer, in my case the <DefaultPrinter ...>
  3. sudo service cups start
  4. Printing should then ask you for the credentials, in my case following the pattern DOMAIN\username and as usual the password, along with a "Remember" checkbox.

Note 1: To see the checkbox, I had to use the "Print ..." option of a recent Gnome application (like Eye of Gnome, eog). It didn't show up in the password dialogue of the job queue.

Note 2: I wasn't asked for a password in the old job queue dialogue reachable via the "Additional Printer Settings ...". However, in the new job queue of the printer directly listed in Gnome Settings->Devices->Printers, one can click on "Jobs" and should see a request for authentication above the queued items.

Currently, it seems that there are two GUI generations mixed in an unfortunate fashion.

Generally, however, printers.conf should not be changed manually which is why waiting for the bug to be fixed seems sensible, too.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.