0

Ubuntu 16.04 server edition, supermicro board

I've installed across 3 Hdds (/ /home /srv) in EFI mode - I set EFI only in the bios before booting, checked install disk integrity and created new GPT partition tables and new partitions for everything. The install goes sucessfully but if I then try and boot in EFI only mode, it won't come up. I can't get anything but the EFI shell (UEFI Hdd is set as priority)

BUT if I boot with the bios set to Dual, rather than EFI, ubuntu boots as expected. Running fdisk -l confirms that everything is partitioned as GPT.

So why won't it boot with EFI only mode set? Am I actually booting in legacy mode somehow?

7
  • 2
    Query to see if UEFI or BIOS [ -d /sys/firmware/efi ] && echo "EFI boot on HDD" || echo "Legacy boot on HDD" May be best to see details, use ppa version with your live installer (2nd option) or any working install, not older Boot-Repair ISO: Please copy & paste link to the Boot-info summary report ( do not post report), the auto fix sometimes can create more issues. help.ubuntu.com/community/Boot-Repair
    – oldfred
    Jan 23, 2020 at 14:32
  • Running the above confirms that I am on Legacy Boot. So an MBR/LEGACY grub2 install must have happened? Even though I booted a GPT formatted USB drive in EFI mode for the install and formatted all Hdds with GPT partition tables? Also: I have a 5TB Hdd that is appearing as 4.6TB in fdisk -l and df -h - but this shouldn't be possible under legacy?
    – ezekiel
    Jan 24, 2020 at 12:11
  • boot-info paste.ubuntu.com/p/Hpr9XGt5VQ
    – ezekiel
    Jan 24, 2020 at 12:16
  • How you actually boot install media UEFI or BIOS, is then how it installs. So you must have booted in BIOS mode. Your Boot-Repair says it is booted in BIOS mode. You also have a grub legacy menu.lst in sdb1. All your drives are gpt. I thought grub2 would not install correctly without a 1 or 2MB unformatted partition with the bios_grub flag. And within the first 2TiB of a drive. See also line 1107 as it reports you are missing bios_grub. When I was first converting from BIOS to UEFI, I included both ESP and bios_grub when partitioning a new drive as first two partitions.
    – oldfred
    Jan 24, 2020 at 19:39
  • Very confusing as the bios was definitely set to EFI-only boot at install time. I only switched it to dual out of desparation just to try something else when I couldn't get my newly installed OS to boot.
    – ezekiel
    Jan 25, 2020 at 0:22

1 Answer 1

1

May be best to see details, use ppa version with your live installer (2nd option) or any working install, not older Boot-Repair ISO: Please copy & paste link to the Boot-info summary report ( do not post report), the auto fix sometimes can create more issues.

https://help.ubuntu.com/community/Boot-Repair

https://sourceforge.net/p/boot-repair/home/Home/

You can check if install is UEFI or BIOS. But how you boot install media UEFI or BIOS is then how it installs. The UEFI settings in UEFI/BIOS are only for the system once installed. Often best to have UEFI Secure Boot off, but then you have options to boot in either UEFI or CSM. CSM - UEFI Compatibility Support Module (CSM), which emulates a BIOS mode, only available with secure boot off.

But how you boot install media is separate. If Secure Boot is off, you should get two boot options for the live installer. One clearly UEFI and other just description of flash drive. My system has UEFI:PMAP or PMAP to boot live installer. The PMAP only is BIOS boot. Most use name or label of flash drive where mine had PMAP.

[ -d /sys/firmware/efi ] && echo "EFI boot on HDD" || echo "Legacy boot on HDD"

If using legacy/BIOS/CSM boot on a gpt drive, you need a bios_grub partition. For UEFI boot you need an ESP - efi system partition. Best not to use MBR(msdos) with UEFI. Windows does not allow MBR with UEFI, but Ubuntu will let you install that way. I suggest always using gpt now. The only time to use MBR, is if drive will have Windows booting in BIOS boot mode.

In UEFI you often have to turn on allow USB boot or full USB support or similar setting. If Secure Boot is on, USB boot not allowed as not considered secure, so allowing USB boot is a separate setting.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.