32

On my Ubuntu 18.04 Bionic Beaver LTS, the following popup appears often when working with Docker and I'm not purposely doing anything that would require a password:

KDE Wallet Service: The application 'kded5' has requested to open the wallet 'kdewallet'. Please enter the password for this wallet below.

enter image description here

The kded5 man page doesn't help me understand what's going on, and I'm not using KDE Wallet, so I always click Cancel, and soon it appears again.

Tried to untick Enable the KDE wallet subsystem via Start->KDE Wallet but this caused my Chromium to "forget" all saved passwords, so it's ticked again, and Chromium "recalled" the saved passwords again - so it turns out I am using KDE Wallet after all.

Tried to untick System Settings->Notifications->(drop down)->Wallet->Needs password->Show a message in a popup, but still it appears.

Q: How to get rid of it without making Chromium unusable, and what is going on? Would be grateful for any hint or link to good documentation. I'm ok if Chromium can be configured to store passwords elsewhere.

EDIT: Found the Chromium --password-store parameter however the only usable (and halfway safe) way seems to be the default, which is KDEWallet (on KDE). Unless I can install the GNOME Keyring on KDE?

2

6 Answers 6

14

It looks like this is coming from the keyring package which is used by pip. Their site lists several ways to disable it. In my opinion the easiest way seems to python -m keyring --disable

This way you don't have to stop using kdewallet, but you stop getting those popups from pip.

5
  • 3
    I get /usr/bin/python: No module named keyring. With python3 (3.6.9) the module is found, but error: no such option: --disable. Probably the option has been implemented in a later version.
    – V-R
    Dec 7, 2020 at 14:05
  • 1
    The other methods listed on their site like uninstalling the module should still work for you.
    – rofer
    Dec 11, 2020 at 23:42
  • i knew python was related, i was using protonvpn-cli which uses python, it uses a cross platform keyring thing and it seems to've glitched
    – mekb
    Aug 16, 2021 at 2:37
  • 1
    pip may be one possible source of this problem, but it appears there are others. I currently have this issue on two Ubuntu machines (20.04 and 22.04), and pip is not and has never been installed on either of them. Aug 14, 2022 at 16:43
  • I did python3 -m keyring --disable for both root and my user login, it still popup.
    – xuancong84
    Apr 12 at 2:18
11

I also faced this problem. For me, it was because I had just changed my user password (same as admin) and kwallet which I guess stores all the passwords (e.g. Wi-Fi password) wasn't aware of the new password. Because of this, I had to enter my Wi-Fi password every time I logged into the system.

To change the password of kwallet, click on this button inside KWalletManager... KWalletManager

Just entering the old password (or new, after changing) into the prompt from kwallet [kded5] fixed the issue for me.

3
  • 1
    Right on the target, @vaibhavsoni! Different from OP, I was only having this popup when opening the browser - and only from the command line (still didn't find the difference). Just like you, my browser stores nothing on KDEWallet, but the reason was the same - I've changed my password and KDEWallet started asking for it. Just had to make KDEWallet's the same one as my user's. Great one! Apr 21, 2022 at 9:59
  • 1
    This is the correct answer. I, too, changed my user password and it didn't propagate to kwallet. Thanks!
    – bitsmack
    Oct 11, 2022 at 15:21
  • I encountered the same issue but I did not change my password. See my answer below askubuntu.com/a/1440712/124466 May 18, 2023 at 3:24
5

Well, you can disable this feature completely under Settings -> Account -> Wallet, untick "Use KDE Wallet".

5
  • 5
    I think you mean System Settings->Personalization->Account Details->Wallet Preferences->Enable the KDE wallet subsystem checkbox (the best match I found in Ubuntu 18.04 for your answer), I've already tried it and it makes Chromium unusable because it unfortunately saves all the passwords there. I will edit the question to clarify the requirement of not breaking Chromium.
    – V-R
    Jan 24, 2020 at 10:11
  • After setting this, the pop-up continues to occur until logging off and back on again.
    – kbulgrien
    Jun 14, 2022 at 15:20
  • 1
    The problem is that kded5 wants to use the wallet. Disabling the KWallet system doesn't stop the problem because kded5 will keep asking to use it (and throwing the annoying modal) whether you have KWallet enabled or not. Aug 14, 2022 at 16:45
  • Yes I have exactly the same problem even though I had totally uninstalled the wallet
    – Asklep
    Aug 30, 2022 at 10:27
  • These settings do not exist in KDE Plasma 5.26 Nov 15, 2022 at 0:17
5

After asking the maintainer of kded5 he has indicated that:

On login, networkmanager tries to connect to the wifi and therefore needs access to kwallet. org.kde.plasmanetworkmanagement is a kded module so the request comes from the kded5 process.

This means that if we disable KDE Wallet the WiFi password will not be saved when restarting.

2
  • As it’s currently written, your answer is unclear. Please edit to add additional details that will help others understand how this addresses the question asked. You can find more information on how to write good answers in the help center.
    – Community Bot
    Apr 19, 2022 at 16:30
  • 1
    This answer gets closest to the source of the problem, but is short of a solution. The WiFi password is stored in /etc/NetworkManager/system-connections/<WiFi name>, which is where Gnome gets it from and why it doesn't pester you constantly for a wallet the way Plasma does. So the question is, how do we get org.kde.plasmanetworkmanagement to get the WiFi password from /etc/NetworkManager/system-connections/<WiFi name> instead of trying to store it in a KWallet wallet? Aug 14, 2022 at 16:50
3

I encountered this issue even without changing the password.

One solution is to install KDE Wallet, and the reset the password to no password.

sudo apt install kwalletmanager

Open the change password screen in KDE Wallet, and save the password with a blank text field.

1
  • 1
    Can someone explain the downvote? Resetting the password in Kwallet has got nothing to do with the system password/system security. Nov 15, 2022 at 0:11
-2

This fixes the problem. I had a user today 05.005.2022, complain about this popup. This is just a little more more explicit because for some people, if this file is blank which was the case for the user I assisted today follow the below instructions;

In the following config file; ~/.config/kwalletrc IF these lines are not in your config, please add them;

[Migration]
alreadyMigrated=true
[Wallet]
Enabled=false

Or If, the file doesn't exist create it and add;

[Migration]
alreadyMigrated=true
[Wallet]
Enabled=false
1
  • This is another way to do what askubuntu.com/a/1205323/115439 suggests. Adding a [Migration] section if one is not already there is likely superfluous. Certainly it is not relevant to the issue at hand as it is not present in the file after using the @emvaized solution to stopping the annoying popup.
    – kbulgrien
    Jun 14, 2022 at 15:17

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .