0

I am new to unbuntu. Please help me with this issue if possible. I have read through many solutions online, yet I am having difficulties understanding what was written by most.

I tried to run an executable from the terminal, however this is the error message that followed.

./magfieldmapper_gui: error while loading shared libraries: liblapacke.so.3: cannot open shared object file: No such file or directory

Please advice. Thank you for your time.

2

This most likely means that the library your program is looking for is not installed. To find out what package this library is in, do this (if apt-file is not found, run sudo apt install apt-file && sudo apt update first):

apt-file search liblapacke.so.3

Your output will be something like this:

liblapacke: /usr/lib/x86_64-linux-gnu/liblapacke.so.3

So, install the package as normal:

sudo apt install liblapacke


|improve this answer|||||
  • Thank you so much for the quick response! – Dr Drill Jan 23 at 5:53
  • Now there seems to be another problem, the next output is ./magfieldmapper_gui: error while loading shared libraries: libcholmod.so.3.0.6: cannot open shared object file: No such file or directory I have tried the same method, as you mentioned, however this time, the error message is E: Unable to locate package libcholmod3.0.6 E: Couldn't find any package by glob 'libcholmod3.0.6' E: Couldn't find any package by regex 'libcholmod3.0.6' Sorry for troubling you. – Dr Drill Jan 23 at 5:57
  • On my Mint system (same base as Ubuntu 18.04), I'm on libcholmod.so.3.0.11. – ajgringo619 Jan 23 at 5:59
  • Yes I understand Sir, however, it seems that this executable requires an older version of libcholmod for it to run. Do you have any idea how I can alter this? – Dr Drill Jan 23 at 6:04
  • 1
    OK. You can try downloading the right version from Ubuntu and installing it, but you may run into more dependency problems. – ajgringo619 Jan 23 at 6:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.