1

I've had a LENOVO 80VQ/Lenovo ideapad 710S-13IKB with Ubuntu 18.04.3 LTS installed for almost 2 years. I don't recall the integrated USB Easycamera ever working and recently it's begun to bother me that I've not found a fix for it. So here's what I've found so far:

$ lsusb
Bus 001 Device 003: ID 13d3:5673 IMC Networks

$ lsusb -t 
/:  Bus 01.Port 1: Dev 1, Class=root_hub, Driver=xhci_hcd/12p, 480M
    |__ Port 5: Dev 3, If 0, Class=Video, Driver=, 480M
    |__ Port 5: Dev 3, If 1, Class=Video, Driver=uvcvideo, 480M

Some output from dmesg when I try modprobe uvcvideo

  [ 1576.626874] media: Linux media interface: v0.10
  [ 1576.632827] Linux video capture interface: v2.00
  [ 1576.757104] uvcvideo: Found UVC 1.00 device EasyCamera (13d3:5673)
  [ 1576.758801] uvcvideo: Failed to initialize entity for entity 6
  [ 1576.758804] uvcvideo: Failed to register entites (-22).
  [ 1576.758822] ------------[ cut here ]------------
  [ 1576.758825] sysfs: cannot create duplicate filename '/devices/pci0000:00/0000:00:14.0/usb1/1-5/1-5:1.0/media0'
  [ 1576.758853] WARNING: CPU: 2 PID: 3977 at /build/linux-vxxS7y/linux-4.15.0/fs/sysfs/dir.c:31 sysfs_warn_dup+0x56/0x70
  [ 1576.758854] Modules linked in: uvcvideo(+) videobuf2_vmalloc videobuf2_memops videobuf2_v4l2 videobuf2_core videodev media ccm ipt_MASQUERADE nf_nat_masquerade_ipv4 nf_conntrack_netlink nfnetlink xfr  m_user xfrm_algo iptable_nat nf_nat_ipv4 xt_addrtype nf_nat br_netfilter bridge stp llc aufs overlay nf_log_ipv4 nf_log_common xt_LOG xt_limit xt_tcpudp nf_conntrack_ipv4 nf_defrag_ipv4 xt_iprange xt_co  nntrack nf_conntrack libcrc32c iptable_filter bnep arc4 nls_iso8859_1 snd_hda_codec_hdmi wmi_bmof input_polldev intel_wmi_thunderbolt snd_soc_skl snd_soc_skl_ipc snd_hda_ext_core snd_soc_sst_dsp snd_soc  _sst_ipc snd_hda_codec_realtek snd_hda_codec_generic snd_soc_acpi snd_soc_core snd_compress ac97_bus snd_pcm_dmaengine snd_hda_intel intel_rapl snd_hda_codec x86_pkg_temp_thermal intel_powerclamp snd_hd  a_core
...
[ 1576.759130] Call Trace:
...
[ 1576.759490] ---[ end trace 8e6b3e85b1b873ca ]---
  [ 1576.759494] kobject_add_internal failed for media0 with -EEXIST, don't try to register things with the same name in the same directory.
  [ 1576.759503] media: media_devnode_register: cdev_device_add failed
  [ 1576.759797] usbcore: registered new interface driver uvcvideo
  [ 1576.759799] USB Video Class driver (1.1.1)

That sysfs warning about duplicate file name seems relevant as it's in the relevant Easycamera directory. Why does ubscore report uvcvideo as registered even though there seems to be an error?

Can I just delete the media0 directory and try reloading the module? Will that cause any serious problems?

This email exchange on kernel.org also seems relevant though I'm not sure.

Any other pointers ? The light on the camera briefly flashes when any application tries to use it. That along with the dmesg error makes me hopeful it's not a hardware malfunction.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.