2

I just upgraded from 18.04 to 19.04 to 19.10 and for a day it was seemingly fine. I removed wayland and using x11 now but today, for some reason, gnome-tweaks just bugged out.

enter image description here

Tweaks opens up like this now. If I toggle a switch, the top bar navigation appears and then I can back out to the main menu:

enter image description here

And I just discovered that if I leave animations off, the whole UI bugs out. Flickering from one state or another.

I tried removing it with sudo apt purge gnome-tweaks and reinstalling but the problem persists.

Can someone shed some light on this please.

3
  • This could be due to the GTK theme you're using. See if changing the theme using dconf-editor (/org/gnome/desktop/interface/gtk-theme) to say Yaru solves this.
    – Logix
    Jan 22 '20 at 12:59
  • @Logix same issue. I just cannot seem to get a handle on this and I don't know which logs to look at to see what's failing.
    – rgin
    Jan 22 '20 at 14:00
  • 1
    Was everything upgraded properly? See if maybe you need to run "sudo apt install -f", then use"sudo apt full-upgrade" to fully upgrade the system. Then check the Tweaks version and see that you're actually using the version in Ubuntu 19.10 using this command: "apt policy gnome-tweaks", it should say version 3.34. Also... you do use GNOME Shell and not some other desktop environment, right?
    – Logix
    Jan 22 '20 at 14:33
0

This issue was caused by some weird issue during the upgrade from 19.04 to 19.10.

When the upgrade ended there were no errors and lsb_release -a showed 19.10 but for some reason after running apt update it showed 19.04.

I ran the upgrade again and everything was fixed.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.