0

Since I installed PulseEffects, the built-in volume control does not work. How can I control the volume with keyboard on PulseEffects?

Details:

  • Also read that could be a Pulseaudio 11 bug, I have upgraded to 12.2 and the issue remains.
  • When I press the volume control buttons, it shows "PulseEffects(mic)" it may even be trying to change volume of the mic instead of the speakers?

I have Ubuntu 18.04, Pulseaudio 12.2, PulseEffects 4.7.0 (installed with Flatpak)

Edit:

  1. I tried setting Settings -> Sound -> PuleEffects(apps) but with this setting it just disabled all sound.
  2. Found a solution, see below.
  • How do you change volume now? Eg GUI, command line or both. – WinEunuuchs2Unix Jan 20 at 20:35
  • I changed it with media control hotkeys of my keyboard (volume +/-) until it worked. Now even adjusting the built-in volume bar with mouse clicks doesn't work. Only adjusting inside the PulseEffects application works. – Patrik Turi Jan 20 at 22:23
  • This will give you an idea of how to debug a problem in PulseEffects: github.com/wwmm/pulseeffects/issues/99 – WinEunuuchs2Unix Jan 21 at 4:51
0

I managed to fix it (thanks for the comments too):

  • Reverted to Pulseaudio 11.1 (it's the default which comes with Ubuntu 18.04)
  • Installed PulsEffects from this PPA (instead of Flatpak, this PPA installs 4.7.1):
sudo add-apt-repository ppa:mikhailnov/pulseeffects -y
sudo apt update
sudo apt install pulseeffects

Went to Settings -> Sound and selected PuleEffects(apps) as Output: enter image description here

And now the volume control and media hotkeys work with PulseEffects.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.