0

First - I have zero idea what I'm doing (ex set-up the computer, prior to being an ex, so now my tech support is gone!). I did try searching already but nothing seemed to help. I apologize in advance for using the wrong terminology.

  • I have an HP Deskjet 2655.

  • I am running this: Distributor ID: Ubuntu Description: Ubuntu 18.04.3 LTS Release: 18.04 Codename: bionic

  • I can use it via USB (in both HP Device Manager and with just the "printer" menu).

  • I tried adding it using the USB connection, and get the message "your printer has been successfully configured to the wireless network. You may now unplug the usb cable. to setup the printer now run ...hp-setup (IP)”

  • when I run the hp-setup, I get this error "HLIP cannot detect printers in your network This may be due to existing firewall settings blocking the required ports.When you are in a trusted network environment, you may open the ports for network services like mdns and slp in the firewall. For detailed steps follow the link."

  • the link doesn't appear to take me anywhere that will help me even find my firewall settings. I tried searching for this too, but cannot manage to find it.

  • I tried connect wirelessly by directing HP to the IP address of the printer, but it still cannot find it.

  • If I type the IP into the address bar it won't load or do anything. I can access my router stuff though (is this where the firewall stuff is?)

Do I have to play around with the firewall stuff? I'm not sure how to access them. My settings only gives me three options "Gigolo, Synaptic Package Manager, and Task Manager." so I don't know where to access the important stuff!

As a note, I can also boot my computer into Windows. I did manage to get the printer set-up wireless in Windows (which was also a giant pain - I'm pretty sure I just managed a work-around and not what I was actually supposed to do), so I'm not sure if that is helpful or not. I really don't fancy booting into Windows to print or scan though, but also I'm scared to totally mess up the computer by playing around or accidentally giving someone access by giving personal info so...

I'm not sure what other information to provide - but if you give me clear instructions I can probably manage to pull whatever info is needed! Also thank you in advance for your patience... =)

  • Did you enable the firewall? With HP wireless printers all I normally have to do is get them connected to the wifi router, open the printer app and click the network printer option and wait for it to be found – Jeremy31 Jan 19 at 21:41
  • I'm not sure which firewall you mean? The printer doesn't show up under "Network Printer" either. I can search for one by host name, but I'm not sure what that is (I tried the IP just in case but that didn't work either). – Kay Jan 19 at 21:58
  • check in terminal sudo ufw status – Jeremy31 Jan 19 at 23:27
  • thank you. status: inactive – Kay Jan 20 at 0:21
  • In a browser address bar type the address localhost:631 . That's the CUPS browser interface. Navigate to the administration tab on the page. After logging to the CUPS page try to add network printer. – da_kingpin Jan 21 at 5:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.