4

Host OS: Ubuntu 18.04

Virturalized: Windows 10

Things I have already done:

  1. Added $USER to the dialout group and rebooted
  2. sudo chmod 666 /dev/ttyUSB*
  3. Mapped the port where my microcontroller gets detected as a Serial communication device to a COM4 port from the settings for the VM

18

Result:

The Device Manager of the VM shows only COM1 and hence no success at serial communication.

2
2

N0rbert's comment did guide in the right direction. I am leaving the answer here with the screenshots as a documentation so that others won't scratch their heads trying to do the setup using Serial port Settings of Virtualbox.

So, the steps are as follows:

  1. Connect your microcontroller via USB.
  2. Open the USB section in the Settings for your VM.
  3. Add the intended device as per the screenshot (by clicking on 2nd icon in the right pane).

USB settings in Virtualbox

  1. Power ON the VM and you will get this error which can be ignored.

Warning message before the VM Boots

  1. Under Device Manager on your VM you will find your device

Device showing on COM3 in VM

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.