0

I'm very new at Linux. I'm running a mediaserver (pms) on Ubuntu 18.04.3 mini, with no desktop or something like that.

Now I'm wondering if it's possible to connect to the server, and run applications like luckybackup GUI, or is it a requirement to have a desktop installed on the server?

0

What you're looking for is called X-forwarding and it can be done. The server will require to have the X11 server-side stuff installed, and SSH will require to be configured to allow it. Have a look here and see if this helps: https://www.addictivetips.com/ubuntu-linux-tips/set-up-x11-forwarding-on-linux/

If you need cross-platform compatibility then Spice project is a bit more involved but might also help: https://www.spice-space.org/

VNC is another cross platform solution. Here's one tutorial but there are probably plenty more out there: https://www.digitalocean.com/community/tutorials/how-to-install-and-configure-vnc-on-ubuntu-18-04

| improve this answer | |
  • I've followed the instructions, but getting an error on the other Linux machine (not the server) qt.qpa.screen: QXcbConnection: Could not connect to display Could not connect to any X display. – JoBe Jan 18 at 17:34
  • Is X11Forwarding enabled on both machines? /etc/ssh/sshd_config on the server, /etc/ssh/ssh_config on the client. – K. Hinch Jan 19 at 8:44
  • Also, from the error it looks like you're forwarding a qt application (and I see Lucky Backup is a qt application). From Googling this it looks like many people are having issues forwarding qt applications, with varying levels of success. It might be worth trying to forward a non-qt application until you get it working, then try Lucky Backup when you know it's working for other things. Any of the bundled Ubuntu apps will likely be non-qt. Try gnome-terminal or something? – K. Hinch Jan 19 at 8:54
  • X11 is now on both, but the same issue. The gnome-terminal says: Unable to init server: Could not connect: Connection refused # Failed to parse arguments: Cannot open display: – JoBe Jan 19 at 10:30
  • Can you also check on your server that /etc/ssh/sshd_config contains: X11DisplayOffset 10 TCPKeepAlive yes And that the ssh service has been restarted since the changes. I just tested this with my own Ubuntu 18.04 server and 18.04 desktop by installing gvim on the server: apt install vim-gtk. Connected with ssh -X <user>@<host> and then gvim and it worked. – K. Hinch Jan 19 at 11:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.