0

I need to update my Nvidia drivers in Ubuntu 18.04.3 LTS, but while installing drivers using below command

$ sudo apt-get install nvidia-driver-410

I am getting this message

...
Secure Boot not enabled on this system
...

I tried to enable the secure boot from BIOS but I am stuck with this error

enter image description here

Actually recently I have updated my BIOS as I was upgrading my CPU, I think after updating the BIOS some settings have been changed

I am not an advanced user, this is the first time I came across this issue and I don’t want to mess up with the BIOS settings, can anyone help me resolve this issue

Motherboard: Asrock B360M Pro 4

Note: I also have Windows 10 installed on other SSD and it works fine, I have installed all the drivers and benchmarked it without any problem

0

(Before you continue: make sure you have an external copy ("backup") of all precious things on your computer.)

There is probably no need to enable secure boot.

You can try removing the shim-signed package like this:

sudo apt-get remove shim-signed
sudo apt-get install nvidia-driver-410

You will need to reboot before the driver is loaded in Ubuntu.

| improve this answer | |
  • Hello @Gogowitsch, Is this command safe to run – Atinesh Jan 18 at 10:35
  • @Atinesh From my experience it is safe to run, if secure boot is currently disabled in your BIOS. – Gogowitsch Jan 19 at 10:51
0

It turns out problem was something else, I left secure boot disabled. Actually after installing Nvidia driver I was also installing CUDA toolkit which has some built in old Nvidia drivers, so while installing CUDA Nvidia drivers was getting corrupted. Hence first I installed Nvidia driver then installed CUDA by not allowing it to install Nvidia drivers and the problem got resolved.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.