0

I am trying to host a openvpn server on my Jetson Nano board (arm64). I followed the tutorial from a digitalocean page, but I cannot connect to my vpn server outside the network. I can however connect when I am inside, even when using noip's ddns. I have also forwarded the port on my router.

Also when i run tcpdump -i eth0 -vv -s 1500 port 1194 I do not see any connection made as well.

This is my client.ovpn (Ofcourse I have remove the certificate and key details)

# Specify that we are a client and that we
# will be pulling certain config file directives
# from the server.
client

;dev tap
dev tun

;dev-node MyTap

;proto tcp
proto udp

remote example.ddns.net 1194
;remote my-server-2 1194

;remote-random

resolv-retry infinite

nobind

user nobody
group nogroup

# Try to preserve some state across restarts.
persist-key
persist-tun

;http-proxy-retry # retry on connection failures
;http-proxy [proxy server] [proxy port #]

#ca ca.crt
#cert client.crt
#key client.key

remote-cert-tls server

#tls-auth ta.key 1

cipher AES-256-CBC
auth SHA256
key-direction 1

#comp-lzo

verb 3

;mute 20

# script-security 2
# up /etc/openvpn/update-resolv-conf
# down /etc/openvpn/update-resolv-conf
<ca>
-----BEGIN CERTIFICATE-----

-----END CERTIFICATE-----
</ca>
<cert>

-----BEGIN CERTIFICATE-----

-----END CERTIFICATE-----
</cert>
<key>
-----BEGIN PRIVATE KEY-----

-----END PRIVATE KEY-----
</key>
<tls-auth>


-----BEGIN OpenVPN Static key V1-----

-----END OpenVPN Static key V1-----
</tls-auth>

Any help will be appreciated. Thank you.

0

Most likely open the necessary ports in your firewall in front of the server.

From the sounds of it this is hosted on a network at home, you are trying to access it from outside. since you can connect to the server from inside your network, but you can not from the outside then one of two things are likely true:

  1. Your trying to connect to the wrong IP
  2. The correct ports (in this case 1194) are not set to route traffic through to your server.

A "typical" setup would be a modem from your isp -> router/switch -> various computers on your lan. The router needs to be told to allow incoming traffic on 1194 to route through to the ip address of your internal server.

Based on your settings file above, you need to allow udp traffic through on port 1194.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.