hello last night my PC got DC'd from the power source and shut down suddenly as far as im aware it wasnt performing any updates or such, it refused to get past loading screen and wouldn't access ttyl, used a live USB to manually sudo fsck -f to fix the issues and it still wouldnt boot past loading screen or get to ttyl.

i can access grub screen and recovery i used systemd.unit=multi-user.target and it allowed me to access ttyl from there i tried to perform fsck and update but it wouldnt allow me to do anything because it says its in read only mode, tried to mount it to rw but its write protected same thing with recovery mode basically, recovery menu says its read/write however when i attempt to repair broken packages or anything it gives me read only errors

please help me get to the root of the issue using. dmesg in recovery mode gives me

[937256380] sd 0:0:0:0: (sda) tag#10 CDB: Read (10)28003869 1800000080

[937256381 ] print_req_error: 1/0 error, dev sda, sector 951711832
[937256417] ata1: EH complete
[940985080] ata1.00: exception Emask OxO SACE 0x200 SErr Ox0 action oxo
[940985083] ata1.00: Irg.stat 0x40000008
[940985087] ata1.00: failed command: READ FPDMA QUEUED
[940985103] ata1.00: cmd 60/80:48:00:f8:b9/00:00:38:00:00/40 tag 9 ncq dma 65
536 in

res 41/40:80:58:f8:b9/00:00:38:00:00/40 Emask Ox409 (med

la error) <F>
[940985104] ata1.00: status: ( DRDY ERR )
[940985105] ata1.00: error: { UNC )
[940988344] ata1.00: configured for UDMA/100
[ 940988357] sd 0:0:0:0: (sda) tag 19 FAILED Result: hostbyte:DID_OK driverbyte
[ 940988360 ] sd 0:0:0:0: (sdal tag 9 Sense Key : Medium Error (current)
[ 940988362] sd 0:0:0:0: (sda) tag 9 Add. Sense: Unrecovered read error - auto
reallocate falled
[940988365] sd 0:0:0:0: (sda) taga9 CDB: Read 10280038 b9 f8 00 00 00 80

[ 940988366]print_req_error: I/0 error, dev sda, sector 951711832
[940988403] ata1: EH complete

my laptop runs on radeon graphics and Intel i7 cpu

edit #1 : pictures of the drive's smart data https://imgur.com/a/GN5myU9

edit #2: after booting to my live usb and taking a picture of the drive's smart data, i preformed a manual fsck on said drive and shut down, then i proceeded to follow @heynnema 's instructions and disabled ncq which solved my problem permenantly :)

  • Your HDD may be failing, or you may have a NCQ error situation. Do this... boot to a Ubuntu Live DVD/USB, start the Disks app, select SMART Data from the "hamburger" menu, take screenshot(s), and update your question, or post them to imgur.com and give me the URL. Do you have good backups? We may run a bad block test on the HDD (you don't have an SSD, correct?). Start comments to me with @heynnema or I may miss them.
    – heynnema
    Jan 16, 2020 at 22:35
  • @heynnema imgur.com/a/GN5myU9 i have only the files backed up no actual save point for the drive but i dont much care for any settings and such. and yes its an hdd
    – Alla kh
    Jan 16, 2020 at 22:46
  • Give me a couple of minutes to write a partial answer for you. Report back after you do the instructions.
    – heynnema
    Jan 16, 2020 at 22:57
  • Did you complete a fsck on the drive?
    – heynnema
    Jan 16, 2020 at 23:07
  • @heynnema yes i did a fsck from live USB before shutting down just in case
    – Alla kh
    Jan 16, 2020 at 23:09

1 Answer 1


Your hard disk may be failing. You may have one of two possible problems with your HDD. Lets try and eliminate the easiest one first.

NCQ errors...

  • turn on the computer
  • get to the GRUB menu
  • assure that the desired boot choice is highlighted
  • hit the e to enter edit mode
  • use the arrow keys to find the string "quiet splash"
  • change that to "quiet splash libata.force=noncq"
  • hit F10 to continue booting
  • see if things are improved

Bad blocking the HDD...

  • Pending

Update #1:

To make the temporary NCQ tweak permanent...

sudo -H gedit /etc/default/grub # edit this file

Find "quiet splash"

Change it to "quiet splash libata.force=noncq"

Save the file.

sudo update-grub # update GRUB

reboot # reboot the computer

In the SMART Data, keep an eye on "Current Pending Sector Count" and assure that it doesn't increase. If it does, then we WILL have to bad block the HDD.

  • it worked!! i booted into log in and logged in no problems!!!
    – Alla kh
    Jan 16, 2020 at 23:10
  • @Allakh let me update my answer with how to make that permanent.
    – heynnema
    Jan 16, 2020 at 23:14
  • i did as told and made it permanent, reboot was successful and no change in the current pending sector count still resting at 3896
    – Alla kh
    Jan 17, 2020 at 0:25
  • thank you so much for your quick help i appreciate it a lot
    – Alla kh
    Jan 17, 2020 at 0:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.