2

I booted Ubuntu Budgie successfully into my new dell precision 7740. But it gets stuck in the grey screen after the grub menu after I select Ubuntu. This happens only in battery mode.

When I start the laptop with AC power, it logs in without any issue. I did the following on the first install to take care of driver issues.

  1. Put modprobe.blacklist=nouveau before booting the first time in the edit option in grub.
  2. Updated Ubuntu Budgie using sudo apt update && sudo apt upgrade -y
  3. Downloaded additional drivers from the Budgie welcome menu.

I don't have any issues with regard to NVIDIA drivers

I do get this message before boot in AC power: iwlwifi 0000:6f:00.0:BIOS contains WGDS but no WRDS After a second or two, the laptop boots normally with no issues and everything functions normally. Sometimes even in AC power, on restart, the screen goes blank after the grub menu and then I have to restart the laptop again but that happens rarely.

The issue is I am not able to get past the gray screen in battery mode. I have madee these changes in the BIOS settings:

Secure Boot off
set SATA to AHCI

I also tried to boot Ubuntu Budgie 18.04 to recheck, but I got a black screen of death even with the power on, so back to 19.10.

Below are some of the common errors from journalctl. I'm not sure which one is contributing to the issue: (converted some nos to x)

[drm:lspcon_init [xxxx]] *ERROR* Failed to probe lspcon
[drm:intel_ddi_init [xxxx]] *ERROR* LSPCON init failed on port D

PAM unable to dlopen(pam_kwallet.so): /lib/security/pam_kwallet.so: cannot open shared object file: No such file or directory
 PAM adding faulty module: pam_kwallet.so
PAM unable to dlopen(pam_kwallet5.so): /lib/security/pam_kwallet5.so: cannot open shared object file: No such file or directory
 PAM adding faulty module: pam_kwallet5.so

lightdm[xxxx]: gkr-pam: unable to locate daemon control file

ucsi_ccg 0-000x: failed to reset PPM!
ucsi_ccg 0-000x: PPM init failed (-110)

nl80211: kernel reports: Attribute failed policy validation
wpa_supplicant[xxx]: Failed to create interface p2p-dev-wlp111s0: -22 (Invalid argument)
wpa_supplicant[xxx]: nl80211: Failed to create a P2P Device interface p2p-dev-wlp111s

I noticed that immediately after logging into a freshly booted 19.10, the system logs in with battery power several times. The issue starts after I update the system for the first time, and then it does not log in battery mode.

2 Answers 2

1

I have the same issue on Ubuntu 18.04 pre-installed by manufacturer (as you mentioned). Also I have a black screen after hibernate, on battery only again. I tried Ctrl+Alt+F1/F2 but nothing appended even after login and reboot blindly.

I also have a Nvidia GPU. This page show a configuration certified pre-install for Ubuntu, without Nvidia GPU. So I supposed the issue may comes from it.

I will notice if I find a solution...

Update : I solved it looking at here.

Adding kernel parameters solves the issue. Posting solution:

in /etc/default/grub add dis_ucode_ldr in this way

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash dis_ucode_ldr"

then

sudo update-grub

It solved both the boot and hibernate issues for me ! Hope it will help you too.

Update2: The grub menu is not visible (purple screen) but waiting or pressing enter do the job to boot on ubuntu.

1

I had the same problem with a Dell Latitude 7400 and Ubuntu 20.04. It booted only while plugged-in. Without plug, it was stuck on the initial DELL screen.

Anyway, from this post I found the same solution of Artefact007 that worked for me. Briefly,

Adding kernel parameters solves the issue. Posting solution:

open terminal and type "sudo gedit /etc/default/grub" (without ")

modify the voice GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" into GRUB_CMDLINE_LINUX_DEFAULT="quiet splash dis_ucode_ldr"

press ctrl + s (save option)

go back to terminal and type "sudo update-grub"

2
  • perhaps you could be more oprecise in the steps taken to solve the issue, like "open terminal" issue the commands ... would help others alot. peace
    – d1bro
    Jun 18, 2020 at 11:10
  • Is it better now?
    – CuriousGuy
    Jun 19, 2020 at 8:58

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .