0

I followed the installation instructions and was unable to access the web UI properly after having logged in. The web page is stuck on "Loading MAAS..." and the dashboard is never shown.

The current MAAS installed is version 2.7. I have also tried installing version 2.6 and it pretty much resulted in the same outcome (the web UI is perpetually stuck on the message "Unable to connect to: ws://hostname:5240/MAAS/ws")

Relevant (maybe) info: the web UI performed a request ws://localhost:5240/MAAS/ws?csrftoken=undefined, but there is no csrf token cookie stored after logging in.

  • In general, it does not help to know which "installation instructions" you "followed". It would help us help you if you showed what you actually typed and the results. "followed" conceals the typos you made while insstalling. – waltinator Jan 16 at 15:45
0

Not sure what fixed it, but it's working now.

I did ufw allow 5240 and reauthenticated after clearing cache and cookies, then the dashboard appeared normally. Checked the cookies and this time the csrf cookie has been set.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.