2

I currently have a Dell Vostro 14 5490. I have trued using Ubuntu 18.04 LTS, but a lot of my hardware is not supported on that release. So instead, I've decided to use Ubuntu 19.10 which works with my hardware (seemingly except for my graphics card or something).

My issue is that whenever I boot into Ubuntu 19.10 I am able to use it but after a short amount of time (10 seconds or so) the operation of the OS mostly freezes. To be more specific, I am able to move my mouse and when I type on my keyboard it lights up, but I am not able to click anything and when I mouse over things they are not highlighted.

It might also be worth noting that I am currently booting from a "try Ubuntu without installing" option whenever I installed the ISO file onto a USB drive using Rufus. Also, it does work fine when I boot it in safe graphics mode. This gives me the impression that something may be wrong with how Ubuntu 19.10 is interfacing with my GPU. Thanks for any help in advance!

  • Did you try a repair Ubuntu with a live disk/USB ? – vishal Feb 4 at 4:59
1
+50

We must make sure that you don't have Nvidia's proprietary driver installed (or any installed pieces of it).

Nvidia's proprietary driver tend to cause problems (aka bugs) in general i noticed mostly happening when is installed with Gnome3 (on Ubuntu) even with Ubuntu's login screen (after login), this does not apply to everyone.

Boot until you see the login screen but don't login.

Press:

Ctrl+Alt+F1

and type you password.

To trace and remove any possible installed pieces of Nvidia even after proper removal done in the past by the Nvidia's uninstaller or even some possible auto-installed portion of it.

Type the followings:

sudo service lightdm stop
sudo nvidia-uninstall
sudo apt purge nvidia*
sudo apt update
sudo apt install mesa-utils nouveau*
sudo reboot

Keep in mind:

If you definitely willing to install at some point the Nvidia's proprietary driver try to install their latest from their website (at your own risk).

Worst case scenario if everything fails:

  1. Install and try a different UI (for ex. xfce) but like i said again you should also aware that Ubuntu's login screen (after login) may also cause problems with the proprietary driver even with other UI's.

  2. Try to live boot to a different Ubuntu base distribution (for ex. Xubuntu) which includes a different login screen.

https://www.youtube.com/watch?v=MShbP3OpASA&t=49m53s

I have the same MX series GPU which is similar to yours (MX110) on my laptop but i use a different distribution and UI (xfce) with graphic driver Nouveau (free open source) which i always prefer.

| improve this answer | |
  • I haven't yet installed the OS. I'm doing that now, though. I am able to install it via the installer in "(Safe Graphics)" mode. Once that's done I'll see if I can run some of the things you're suggesting and get things to work – xorist Feb 10 at 0:28
  • This seemed to work. After a follow your instructions and a couple of restarts, I have no more issues. Thanks! – xorist Feb 10 at 1:06
0

Check your Service Manual

  • Ensure items such as TPM are turned off.
  • All other BIOS options google the option + Linux to see what settings should be.
| improve this answer | |
  • Does TPM being "visible to the OS" effect Ubuntu's ability to continue to perform? It does bootup and it does allow me to use it for a short time. – xorist Feb 9 at 23:35
  • @xorist TPM and Linux is "complicated": wiki.archlinux.org/index.php/Trusted_Platform_Module – WinEunuuchs2Unix Feb 9 at 23:41
  • I've disabled TPM. I am continuing to have the same issues. Currently I do have some options that I can't seem to find any good resources for online; SATA Operation. It is currently set to RAID On (SATA is configured to support Intel Rapid Restore Technology). My other options are AHCI and Disabled. I'm not sure if this could be causing an issue or not? – xorist Feb 9 at 23:46
  • Yes AHCI should be used according to many: askubuntu.com/questions/963087/… – WinEunuuchs2Unix Feb 9 at 23:55
  • askubuntu.com/questions/1135590/… "Removing /lib/firmware/amdgpu/raven_dmcu.bin and running sudo update-initramfs -u -k all solved this problem." Removing /lib/firmware/amdgpu/raven_dmcu.bin and running sudo update-initramfs -u -k all solved this problem. – pierrely Feb 14 at 10:05
0

You might try installing this BIOS update from Dell to see if that helps at all. I believe you should be able to install this in safe graphics mode.

https://www.dell.com/support/home/us/en/04/product-support/product/vostro-14-5490-laptop/drivers Specifically: https://dl.dell.com/FOLDER06046211M/1/Inspiron_5490_5498_5590_5598_Vostro_5490_5590_1.5.1.exe

You might also try 18.04 - LTS releases can be a bit less flaky in my experience.

| improve this answer | |
  • What does safe graphics mode do on Ubuntu? Will it inhibit my experience in regards to light gaming or utilization of the graphics card? – xorist Feb 9 at 23:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.