1

I recently upgraded from Ubuntu 18.04 to 19.10 on a ThinkPad T480. After the upgrade I recognized, that my touchpad isn't disabled while typing.

I found this thread (How can I disable touchpad while typing? On Ubuntu 16.04 syndaemon isn't working) and I think, that I have the same problem. I have multiple touchpad drivers installed.

$ xinput list

⎡ Virtual core pointer                      id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ Synaptics TM3276-022                      id=14   [slave  pointer  (2)]
⎜   ↳ TPPS/2 IBM TrackPoint                     id=15   [slave  pointer  (2)]
⎣ Virtual core keyboard                     id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Power Button                              id=6    [slave  keyboard (3)]
    ↳ Video Bus                                 id=7    [slave  keyboard (3)]
    ↳ Video Bus                                 id=8    [slave  keyboard (3)]
    ↳ Sleep Button                              id=9    [slave  keyboard (3)]
    ↳ Integrated IR Camera: Integrate           id=10   [slave  keyboard (3)]
    ↳ Integrated Camera: Integrated C           id=11   [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=12   [slave  keyboard (3)]
    ↳ ThinkPad Extra Buttons                    id=13   [slave  keyboard (3)]

Is it right, that I have installed two touchpad drivers (Virtual core XTEST pointer and the Synaptics driver)?

I tried to disable one, but it doesn't work:

$ sudo xinput -disable 4

X Error of failed request:  BadAccess (attempt to access private resource denied)
  Major opcode of failed request:  131 (XInputExtension)
  Minor opcode of failed request:  57 ()
  Serial number of failed request:  21
  Current serial number in output stream:  22

How can I remove/disable one driver? How can I configure them, so that my touchpad is disabled while typing?

0

Every master pointer has a Virtual Core XTEST slave. You need not disable that to disable your touchpad. Instead, you can simply disable the Synaptics one and it should be good enough. In this case,

sudo xinput disable 14

should do the job.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.