1

I have Ubuntu 18.04. I tried to install boost library. During installation my laptop (Dell Latitude 5580) was frozen and I shut it down with power button. Then I switched on it again. I try to log in, it logs me in, background image is shown but immidiately it logs me off again.

Removing .Xauthority file --> didn't help. Removing nvidia driver --> didn't help. Installing new nvidia driver --> didn't help.

I can log in with console (Ctrl+Alt+F2). I created a new user and I can log in as new user. But I can not log in as normal user.

Where can I see an error log? Is it related to desktop manager or nvidia driver or xorg? How can I correct this issue?

New contributor
Mübin Icyer is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.
  • You say it logs you out straight after login. However, do you get your desktop at all or does it go to black screen and then back to login ? – Oskar L Jan 14 at 14:15
  • Sometimes I see only background image and mouse, sometimes only black screen and mouse. And sometimes :) I see desktop symbols as well but only shorter than 1 second. – Mübin Icyer Jan 14 at 14:22
  • Since you using Latitude I'm guessing there is no graphics card in there. Try removing nvidia drivers and run ubuntu-drivers autoinstall – Oskar L Jan 14 at 14:26
  • I run sudo apt-get purge nvidia* and then sudo ubuntu-drivers autoinstall. It didn't help. But if it is driver problem then why is login as other user working? – Mübin Icyer Jan 14 at 14:32
  • Sorry my fault, I somehow missed that bit where you said you can log in as another user. It definitely is not driver fault in this case. Maybe the installation you were doing overwritten some permissions in your home directory ? just try the following commands to get your permissions back to normal. Chmod -R 755 /home/user chown -R user /home/user – Oskar L Jan 14 at 14:51
0

I finally found the solution. This problem may have many many reasons. I changed permissions for Xauthority file, removed nvidia driver. Nothing helped. My problem was gnome shell extension. Somehow file names for gnome shell extensions are corrupted. I deleted all the extension files in ~/.local/share/gnome-shell/extensions and /usr/local/share/gnome-shell/extensions/. All file names were with single quote like ~/.local/share/gnome-shell/extensions/'xxx@xxxuser'. It works now.

Your Answer

Mübin Icyer is a new contributor. Be nice, and check out our Code of Conduct.

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.