5

After switching audio output to a bluetooth speaker the Volume Control widget in the panel cannot be used. A manual setting is needed to select the new output in the widgets' configuration.

enter image description here

I could add a second instance of Volume control widget to the panel and try to use that only for bluetooth, but that looks a bit odd...

  • Is there some way to make the LXQt panel Volume Control follow the actual audio output?

  • Can I use a different volume control tool with that panel?

4

A solution is to use a different tool and remove completely that widget.


sudo apt install kmix

By default the actions on the tray icon don't affect the bluetooth speaker, until that speaker is selected as master channel (righ-click the icon, "Select Master Channel").

enter image description here

It shows no volume change pop-up on mouse actions on the tray icon (at least not in this LXQt).


sudo apt install qasmixer

Resize the window and drag it close to the volume icon.

enter image description here


sudo apt install pasystray

It doesn't show a slider, nor a pop-up, and mouse actions are limited to scrolling volume up-sown (no mute), but it has other useful options like switching the audio output. More here.

Add qasmixer -t (start minimized in tray) and/or kmix & pasystray to startup list.


Furthermore, if the bluetooth audio device volume cannot be controlled through the laptop keys, the following commands could be associated to the keys:

Toggle mute: `amixer -q -D pulse sset Master toggle`

Volume up by 5%: `amixer -D pulse sset Master 5%+`

Volume down by 5%: `amixer -D pulse sset Master 5%-`

Source here and here.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.