I have a laptop mySN QMG6 / Chiligreen Mobilitas NW which is Quanta TW9 barebone with intel i3 and nvidia 335m GT onboard. On ubuntu distros 10.04, 10.10, 11.04 and 11.10 i had problem with changing screen backlight with nouveau and nvidia drivers. FN+F4/F5 buttons did not change my brightness. I tried to edit xorg.conf, adding

Option “RegistryDwords” “EnableBrightnessControl=1″

Also tried to add some lines to grub

acpi_osi="Linux" acpi_backlight=vendor

Neither worked for me. Today I installed Ubuntu 12.04 beta2 and... With nouveau driver my FN key works, and changes the brightness (is it a new 3.0.22 linux kernel, or patched nouveau driver, i don't know). This is a big step forward. But, when installing proprietary nvidia driver (295.33) FN button stops working and i can't change brightness. I also tried workaround with xorg and grub with no result. Tried to install acpi from apt - no result. Is there anything left to try? I really need that nvidia driver working with FN keys, as i would like to have a working 3D acceleration.

P.S. Does the nouveau driver has 3d acceleration like nvidia drivers??? If there is need to provide some log data, please write what should i print, as i'm a bit new to Ubuntu.

P.P.S. Same problems i had with other Linux distros (Mint, Fedora and others)

P.P.P.S. Other FN buttons work with both drivers (Mute, VOL UP/DOWN, WiFi on/off, Bluetooth, Sleep, Start/Pause, Stop, Next/Prev song)

Some new thoughts...


could this be an issue? Made this by

grep BACKLIGHT /boot/config-3.2.0-22-generic-pae

Full grep output can be viewed here: http://pastebin.com/sMRd2Z4k


Got my nvidia backlight working with https://github.com/guillaumezin/nvidiabl So there was no need to reconfigure kernel or other things


Type su and enter root password in terminal

And then type this :

echo "x" > /sys/class/backlight/acpi_video0/brightness

where x = 0 - 7

  • Thanks for a hint. Tried to type this : echo "x" > /sys/class/backlight/acpi_video0/brightness where x = 0 - 7 But got an answer:bash: /sys/class/backlight/acpi_video0/brightness: No such file or directory
    – Vladimir
    Apr 10 '12 at 10:57
  • removed the link .. ;)
    – Sakti
    Aug 20 '12 at 16:15

use my new method for Nvidia Graphics and it hopefully will help you.. thats only thing worked for me.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.