1

youtube-dl downloads neither videos nor mp3. This is the command I use:

youtube-dl --extract-audio --audio-format mp3 <Youtube URL>

The output:

m62iekbg9eo: "token" parameter not in video info for unknown reason; please report this issue on https://yt-dl.org/bug . Make sure you are using the latest version; see https://yt-dl.org/update on how to update. Be sure to call youtube-dl with the --verbose flag and include its complete output.

The version is 2018.03.14. I upgraded it using pip and it said it is upgraded. But when I asked the version youtube-dl --version it still shows me 2018.03.14.

So I deleted youtube-dl and installed it again with pip. The commands I used:

sudo apt-get remove youtube-dl
sudo apt-get install python-pip  
pip install --user youtube-dl

But now, when I try to donwload an mp3 it says:

bash: /usr/bin/youtube-dl: No such file or directory

Also I use 18.04.3 LTS

1
  • You haven't given your release details, nor if you actually installed the program using apt package tools if you removed it before using python-pip to upgrade/install it. I suspect you've two versions installed; but it's unclear from your description.
    – guiverc
    Jan 13, 2020 at 8:57

2 Answers 2

5

Remove an youtube-dl packages from your system.

sudo wget https://yt-dl.org/downloads/latest/youtube-dl -O /usr/local/bin/youtube-dl
sudo chmod a+rx /usr/local/bin/youtube-dl
  • First one draws the program from git, and saves the file under /usr/local/bin/

  • Second one makes it executable.

This is the up-to-date version direct from git. From time to time you have to update the programm with

sudo youtube-dl -U
5
  • Thanks, this solved my problem with a sligtly change on the command where /usr/local/bin/youtube-dl is simply /usr/bin/youtube-dl
    – sarp
    Jan 13, 2020 at 9:42
  • You should let it in /usr/local/bin/ this is in your $PATH.
    – nobody
    Jan 13, 2020 at 9:46
  • But it gives the same error: bash: /usr/bin/youtube-dl: No such file or directory
    – sarp
    Jan 13, 2020 at 10:15
  • Okay then make a softlink sudo ln -s /usr/local/bin/youtube-dl /usr/bin/youtube-dl but /usr/local/bin should in your $PATH. echo $PATH
    – nobody
    Jan 13, 2020 at 10:25
  • You just need to open a new terminal window and issue the youtube-dl command there, after uninstalling the apt version, to avoid the the path mangling issue
    – matanster
    Jun 24, 2020 at 19:14
0

I would suggest removing all youtube-dl packages from your system, so that when you run youtube-dl you will get Command not found error.

After that, run the command (as root user or prefixed with sudo):

 # pip install -U youtube-dl

It will install youtube-dl to path /usr/local/bin/youtube-dl.

Note: Before using youtube-dl in the future, run the above command to update it to the latest version.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.