I recently switched to Ubuntu 18.04 and had no trouble connecting to my university wifi or my wifi at my parents house, but I've been unable to connect to my wifi in my apartment. I also can't connect to the hotspot from my other computer (right now I'm on a mobile hotspot). I've tried a lot of different things (I can't remember the myriad of things I've tried, but I've absolutely tried the basics, like restarting my network manager or going into nmtui or writing the passwords directly into the files in /etc/NetworkManager/system-connections, or the conf file(s) in /etc/modprobe.d). Below is the output from a program I downloaded from this link that is supposedly all the relevant information I need to supply. Let me know if there's something else I can provide that might help deduce the problem.



We see several defects in your system from your supplied paste. Let's fix them and see if there is any improvement.

You've made changes to the file /etc/network/interfaces that are incorrect and, indeed, harmful. Please correct them:

sudo nano /etc/network/interfaces

Correct the file to read:

auto lo
iface lo inet loopback

Save (Ctrl+o) and exit (Ctrl+x) the text editor.

Next, there is no Ubuntu module named '8265':

sudo rm /etc/modprobe.d/8265.conf
sudo rm /etc/pm/sleep.d/config

Next, you haven't any rtl8723be device:

sudo rm /etc/modprobe.d/rtl8723be.conf

Next, ant_sel is not an available parameter for asus_nb_wmi:

sudo rm /etc/modprobe.d/asus_nb_wmi.conf

Next, you have overwritten the needed wording in iwlwifi.conf. Please amend the file:

sudo nano /etc/modprobe.d/iwlwifi.conf

Change it to read:

# /etc/modprobe.d/iwlwifi.conf
# iwlwifi will dyamically load either iwldvm or iwlmvm depending on the
# microcode file installed on the system.  When removing iwlwifi, first
# remove the iwl?vm module and then iwlwifi.
remove iwlwifi \
(/sbin/lsmod | grep -o -e ^iwlmvm -e ^iwldvm -e ^iwlwifi | xargs /sbin/rmmod) \
&& /sbin/modprobe -r mac80211

Save and close as above. I have omitted the parameters you added, namely 11n_disable=1 and disable_msix=1, as I doubt highly that they are useful here.

For the same reason, please do:

sudo rm /etc/modprobe.d/iwlwifi-opt.conf

Next, I recommend that your regulatory domain be set explicitly. Check yours:

sudo iw reg get

If you get 00, that is a one-size-maybe-fits-all setting. Find yours here: http://en.wikipedia.org/wiki/ISO_3166-1_alpha-2 Then set it temporarily:

sudo iw reg set IS

Of course, substitute your country code if not Iceland. Set it permanently:

sudo nano /etc/default/crda

Change the last line to read:


Proofread carefully, save and close the text editor.

Since you are having trouble with just your own access point and none others, we suspect the settings in the router. Here are some tips that I suggest you implement in your router.

First, check the settings in the router. WPA2-AES is preferred; not any WPA and WPA2 mixed mode and certainly not TKIP. Second, if your router is capable of N speeds, you may have better connectivity with a channel width of 20 MHz in the 2.4 GHz band instead of automatic 20/40 MHz, although it is likely to affect N speeds. I recommend a fixed channel, either 1, 6 or 11, rather than automatic channel selection. Also, be certain the router is not set to use N speeds only; auto B, G and N is preferred. After making these changes, reboot the router.

Reboot the computer and tell us if there is any improvement.

  • Thanks for the reply! Unfortunately, I still couldn't connect to the wifi in my apartment. How do I change/check the settings of the router? I think it's defaulted to WPA and WPA2 Personal (according to nmtui). Are the things you discuss software on my computer/that need to be downloaded, or are they specific hardware that I need to get for my router? – Mach Jan 13 '20 at 18:23
  • Also, I don't know if it's worth noting, but here's the output I got from checking the regulatory domain: pastebin.com/Y76WtnBG Since I'm in the US, I went ahead with your code but changed IS to US. – Mach Jan 13 '20 at 18:32
  • You change the settings in the router by logging in to the administration pages of the router; there you will find many settings that you can set to suit your own needs. For example: setuprouter.com/router/arris/dg860p2/wifi-setup-85527.jpg The changes I suggest down to regulatory domain are on your own computer. Simply open a terminal and execute them one by one. Please ask if you are unsure or have further questions. – chili555 Jan 13 '20 at 22:58
  • Ah. That's it. What I thought was the password to my wifi was actually the password to my wifi with 3 extra digits in front of it. I got it from a sticker on the router. But upon logging into the router from a different computer, the actual shared key was the same thing minus those first three numbers. That's embarassing. Anyway, thanks for the help! It's good that you helped me fix the mistakes I made in some files from messing around with them and I wouldn't have thought to check that section of the router page if you didn't suggest it. Thanks so much! – Mach Jan 14 '20 at 2:12
  • If my answer has been helpful, please accept it: askubuntu.com/tour Glad it's working! – chili555 Jan 14 '20 at 2:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.