I installed Ubuntu 19.10 on my new Lenovo 14w laptop and I noticed that the fans are not running at all, causing high temps.

I have installed fancontrol but couldn't figure out the config.

Running pwmconfig results in an error There are no pwm-capable sensor modules installed

And lastly, sensors-detect shows I have AMD Family 15h thermal sensors (driver 'k10temp')

Some posts seem to mention that some Lenovo models have their fans controlled by the UEFI BIOS, however there aren't any such options in my BIOS.

What can I do to get the fan spinning?

Edit: Here's the full sensors-detect output. Couldn't fit in this post due to character limit

  • post the full output of sensors-detect
    – rtaft
    Jan 13, 2020 at 13:54
  • @rtaft added full output Jan 13, 2020 at 22:55
  • I don't think fancontrol is going to work, I'm not seeing anything you can use with pwm. thinkfan might be the way to go, I don't have any experience with that. Does /proc/acpi/ibm/fan exist?
    – rtaft
    Jan 14, 2020 at 13:11
  • @rtaft /proc/acpi/ibm folder does not exist Jan 14, 2020 at 13:38
  • Does it exist after installing thinkfan? What is in /proc/acpi? thinkfan is acpi based instead of pwm.
    – rtaft
    Jan 14, 2020 at 14:45

1 Answer 1


Try to Restore BIOS to the default settings.

Press F2 repeatedly when the Lenovo logo appears on the screen, then F9 Restore to the default settings.

Here's the Lenovo 14w user guide if you want to try updating your BIOS to the latest version

try to adjust lm-senors and fancontrol parameters following this guide:

How to control fan speed?

Run :

fwts fan

to check and test fan status, or as How do I know my fan is working in Ubuntu

Finally you can check The thinkfan software is available in the standard ubuntu software repositories, but it does require a few steps to configure.

How to control fan speed?

  • Went through the steps but the thinkfan service can't start due to /proc/acpi/ibm/thermal not existing. I also made sure to upgrade the BIOS before uninstalling Windows. Jan 15, 2020 at 15:26
  • Check these for more details on thinkfan: thinkwiki.org/wiki/How_to_control_fan_speed askubuntu.com/questions/481459/… Would you try installing Ubuntu 19.04 or older versions instead of 19.10 as a temp solution to see if this fixes the situation or not, as .04 often are LTS and better-maintained Distribtutions. Jan 19, 2020 at 21:05
  • LTS Ubuntu did not make a difference, manually controlling the fans with echo level x > /proc/acpi/ibm/fan didn't work, and thinkfan service can't be started as it relies on /proc/acpi/ibm/thermal which doesn't exist :/ Jan 21, 2020 at 13:58
  • Do you have these settings : From the main BIOS menu, choose ‘System Monitor’. Then go to ‘Fan Control’ option and select ‘CPU Fan Speed Control’. • Change the control to ‘Manual’ if it is on ‘Automatic’. You can enter the percentage of the CPU fan to work according to your suitability (like 100 will be 100%). ? Jan 22, 2020 at 21:38
  • As I mentioned in my post, nothing fan related exists in BIOS. Jan 22, 2020 at 21:40

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .