8

I am running Ubuntu 19.10 as the only OS on my laptop. Up until recently, that is a few days ago, I regularly watched ITVHub in the Chrome browser on my laptop.

Yesterday I tried to watch a programme only to get the warning that I needed to enable "Protected Content" in Chrome or "Digital Right Management (DRM) Content" in Firefox. I tried to stream the programme in Firefox but got the same warning. I checked and the options were enabled in the Chrome and Firefox browsers. I can stream the BBC iPlayer and All4, two other UK streaming sites without any problem.

I then tried streaming ITVHub using Chrome in my Android tablet and it worked perfectly.

I regularly update my Ubuntu OS and there was an update prior to this problem occuring. Because Chrome can stream ITVHub on my Android tablet but not on my Ubuntu laptop I suspect the problem may be an OS problem.

I have all of the ubuntu-restricted-extras etc installed and the ITVHub was working on my 19.10 OS until very recently.

Any ideas of what may be causing this?

6
  • I have found out that ITV may still be using Adobe Flash and thought that might be the reason for the streaming failure. I have tried activating Flash in Chrome but that didn't fix the problem. I would be really grateful for any clues as to what is wrong with ITV streaming under Ubuntu 19.10. Jan 14, 2020 at 9:15
  • 1
    I have the same problem with ITVHub (and BritBox) - other streaming services (BBC, Netflix, Amazon) are fine. The problem is the same in Firefox (72.0.1) and Chrome (79.0.3945.130) (with DRM enabled in both). I note that both ITVPlayer and BritBox are getting an error 400 from a call to itvpnp.live.ott.irdeto.com/Widevine/getlicense as the page loads (this returns with a successful 200 response in Windows). This was all working fine in December. Not clear if this is deliberate blocking of Linux, a bug in the ITV code, or a bug in the browser. Jan 16, 2020 at 22:36
  • @James Shade Thanks for that! I looked at the folder manifest.json in file/opt/google/chrome/WidevineCdm and noticed that it didn't have a linux OS under the "Platforms" section. I added "os": "linux", "arch": "x86", "sub_package_path": "_platform_specific/linux_x64/" to this file and did a complete reboot but still not working. Jan 17, 2020 at 12:18
  • 1
    I have this problem on Ubuntu 18.04 with maxdome.de on Chrome and Firefox. Jan 30, 2020 at 20:43
  • 1
    Same problem for me on multiple Linux distributions and browsers. Not a fix but a sort of workaround is that the STV player doesn't have drm and shows mostly the same programme schedule.
    – match
    Feb 1, 2020 at 17:17

6 Answers 6

2
+25

Not exactly an answer, but I can't post a comment...

I emailed ITV about this problem and received this reply:

Thank you for your email.

I'm afraid that Linux hasn't ever been fully supported on our website.

We are however looking into an issue where DRM content is causing a error message to appear on our website.

If you are getting a message to update your browser, this will probably be resolved for you once they have fixed the issue with DRM content.

If I can be of further assistance, please do get back in touch. 

So I guess we wait and see, but doesn't sound hopeful. It's not clear to me who "they" are (as in "...once they have fixed..."); ITV or browser authors? Nor if this is definitely related to the problem - I have not been prompted to update my browser.

1

ITVHub have replied to my emails confirming that the issue is a "Widevine issue". They said that they hoped to resolve the issue by last Tuesday but, as I wrote and told them, it has still not been resolved.

I'm afraid this is not a lot of help to Martin Thoma but at least he could write to MaxDome.de and specify that ITV-Hub recognize that it is a Widevine issue.

1
  • I recieved this from ITVHub today: "Our technical team are investigating the issue with the ITV Hub on Linux devices (e.g. Chromebooks), as it seems that a recent update is preventing playback, they released a testing update last week, however this didn't fix the issue. They are working to have this fixed and are aiming to release a completed update within the next week. As soon as we have rolled out the fix, we will update viewers from our service status page: help.itv.com/hc/en-us" Feb 6, 2020 at 7:24
1

This is the reason for some streaming-services not working with linux and chrome OS anymore:

https://www.widevine.com/news

They need to set an override for the new standard-rule:

All Widevine browser-based integrations (platforms and applications) must support VMP.

Only Windows- and Apple- based Browsers support VMP (verified media path). Android is still working, because widevine is implemented in Android OS, but not in the browser.

0

I have has some problems playing DRM content when the resolution is set higher than 1080p. As far as I can tell in my case; this is because DRM components often are proprietary black-box DRM setups that negotiate an unbroken chain of DRM from decryption to screen. These are not available as open-source, and therefore not in Linux. Microsoft and Intel probably regard this DRM as a competitive advantage they can offer to rights-holders.

I suspect that your ITV would work on Windows with high resolution in the default browser. Alternatively set the resolution to 720p (good enough for streaming on a PC) and try again since the DRM implemented in Firefox supports that for sure.

1
  • 1
    Even with a resolution of 1368x768 I cannot play the stuff anymore Feb 3, 2020 at 7:44
0

I contacted ITV support and they said that they intentionally didn't support Linux. I used Virtualbox to run W10 and it still didn't work using "Edge" but did with FF until today when it bombed halfway through.I think they're paranoid about people skipping ads.

0

Since yesterday ITVHub seems to be working again.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .