0

So, i wish i saw this https://askubuntu.com/a/958124/952708 two minutes earlier before i purged zsh from my wsl, but alas.

How does one access bash assuming .bashrc has zsh set as default?? Thank you <3

  • What exactly do you mean by ".bashrc has zsh set as default"? did you set zsh as your login shell (via chsh for example), or is bash still your login shell but you are then spawning (or exec'ing) zsh from your .bashrc? – steeldriver Jan 11 at 3:31
  • @steeldriver i'm not sure to be honest. I know I ran sudo chown -R [yourusername]:staff .oh-my-zsh .zs .zsh* a while ago, but that's permissions so far as i know. Otherwise, the latter, i think. Whenever i run Ubuntu from Start it opens up for a sec and dies before prompt appears. bash in PowerShell elicits -bash: exec: zsh: not found – tractatusviii Jan 11 at 3:34
  • OK so it sounds like the latter - maybe try changing the default user to root and then editing your user's .bashrc (or replacing it with the default one from /etc/skel) – steeldriver Jan 11 at 3:47
  • @steeldriver that thread was it. Thanks a ton, should post as an answer! – tractatusviii Jan 11 at 17:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.