Every time I run a software update and shut down my computer, it breaks on the next boot.

This time, it hangs on the login screen. I can't move my mouse, nor type on the keyboard.

I have a Dell XPS 13 7390 laptop.

Bios Version: 1.3.1
Ubuntu 18.04 Bionic Beaver

I thought it might be a video driver problem and have tried adding nomodeset to grub kernel to no avail.

Errors in journalctl -b:

MODSIGN: Couldn't get UEFI MokListRT
PKCS#7 signature not signed with a trusted key
Unable to register Frequencey manager -22
pam_systemd(su:session): Failed to connect to system bus: No such file or directory

I am not convinced any of these are connected to my problem.

Other things to note: I am unable to connect to the internet in recovery mode, even with eth connected I can't ping anything. Trying to enable networking in recovery mode also hangs with no human-readable errors.

Before I resorted to a factory reset, but this time I am trying to avoid that at all costs.

Any guidance would be appreciated.

  • Please click edit and put into your questions each step you performed to upgrade.
    – K7AAY
    Jan 11, 2020 at 0:19

2 Answers 2


Have you tried ALT+F2 or ALT+F3 to get another login screen? I think ALT + F10 takes you to system log where you can see what happened.


Had the same issue.

For me it was a problem with the kernel Linux 4.15.0-1066-oem

Restart and hit Esc to enter GRUB bootloader - select advanced options and boot from Linux 4.15.0-1065-oem (assuming you have that).

You can then remove 1066 from your packages and await Dell fixing it in 1067...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.