0

I'm new to ubuntu. I'm running 18.04.3 from a USB drive on a Lenovo 130S-11GM laptop. It finds the bluetooth adapter ok, but it can't find the wifi adapter.

The adapter is an Intel Dual Band AC3165.

I ran the sudo rfkill list command and it showed the following:

0: ideapad_wlan: Wireless LAN
Soft blocked: no
Hard blocked: yes
1: ideapad_bluetooth: Bluetooth
Soft blocked: yes
Hard blocked: yes
2: hci0: Bluetooth
Soft blocked: yes
Hard blocked: no
3: phy0: Wireless LAN
Soft blocked: no
Hard blocked: no

BTW, the bluetooth works just fine.

I ran the sudo rfkill unblock all command, but nothing changed.

I ran the command: cat /etc/modprobe.d/blacklist-ideapad.conf And the result was the following: cat: /etc/modprobe.d/blacklist-ideapad.conf: No such file or directory.

I ran the command "uname -r" which returned the result "5.0.0-23-generic".

I ran the command "dmesg | grep iwl" which returned the following:

  [   31.755409] iwlwifi 0000:03:00.0: loaded firmware version 29.1044073957.0 op_mode iwlmvm
  [   31.887621] iwlwifi 0000:03:00.0: Detected Intel® Dual Band Wireless AC 3165, REV=0x210
  [   31.915790] iwlwifi 0000:03:00.0: base HW address: a0:51:0b:11:d7:fd
  [   32.076604] ieee80211 phy0: Selected rate control algorithm 'iwl-mvm-rs'
  [   33.576920] iwlwifi 0000:03:00.0 wlp3s0: renamed from wlan0

Thanks.

**NOTE******* Whereas I never could get it to work with Ubuntu 18.04, it works fine with Ubuntu 19.10 "right out of the box".

5
  • When I click on the little triangle in the top right corner, the drop-down windows shows "Wi-Fi-Hardware Disabled". Then I click on that and then select Wi-Fi Settings, the resulting window displays a big question mark with the message "No Wi-Fi Adapter Found", "Make sure you have a Wi-Fi adapter plugged and turned on". When I boot to the installed Windows 10, the adapter is "found" and works fine. – bartimusmaximus Jan 10 '20 at 17:52
  • My apologies for the unformatted edit. I can't seem to figure out why it eliminates all my formatting (indents, spaces, etc). – bartimusmaximus Jan 10 '20 at 18:16
  • "Hard Blocked" means a hardware switch, and cannot be controlled in software. Look for a keyboard toggle, usually one of the Fn-keys. Good reference: askubuntu.com/a/98719/19626 – user535733 Jan 10 '20 at 18:24
  • Please check whether the wifi driver is enabled in Software and Updates, under the Additional Drivers tab. That should fix the problem if it falls under that category... – NanaFox Jan 11 '20 at 17:19
  • I did that. It says "No additional drivers available" in the middle of the window and "No proprietary drivers are in use" on the bottom left. I'm sure I need to install one, but without connectivity I can't figure out how. – bartimusmaximus Jan 11 '20 at 19:54
-1

Please visit

https://www.intel.in/content/www/in/en/support/articles/000005511/network-and-i-o/wireless-networking.html?productId=89450&localeCode=in_en

Download the driver for your Adapter.

Unzip the files and copy 2 files with .ucode extension to /lib/firmware.

2
  • There is no "driver" there. The driver and fimware are loaded already. – Pilot6 Jan 10 '20 at 18:41
  • OK, remember, there's no connectivity on this machine. So I downloaded it using another machine onto a separate USB drive. Can't figure out how to install it. Also booted Ubuntu up on my mac (from a USB drive) and downloaded it there. Still can't figure out how to install it. – bartimusmaximus Jan 11 '20 at 14:47
0

Run in a terminal

sudo tee /etc/modprobe.d/blacklist-ideapad.conf <<< "blacklist ideapad_laptop"

and reboot.

That should fix the hard block.

4
  • @karel It can be marked as a dupe of one of my ansers where I explained that in details, but I can't find it. – Pilot6 Jan 11 '20 at 10:24
  • I ran this an nothing changed. Still says hard block: yes. – bartimusmaximus Jan 11 '20 at 14:07
  • Can you post the output of rfkill list TO YOUR QUESTION. The full output. – Pilot6 Jan 11 '20 at 15:41
  • And also output of cat /etc/modprobe.d/blacklist-ideapad.conf – Pilot6 Jan 11 '20 at 15:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.